IBM Support

Accessing Report Builder results in HTTP Error 404

Troubleshooting


Problem

Attempts to access Report Builder page in IBM Jazz Reporting Service (JRS) result in "HTTP Error 404: SRVE0190E: File not found: /web".

Symptom

The following error message is displayed when you try to access the Report Builder web interface:
Error 404: javax.servlet.ServletException: java.io.FileNotFoundException: SRVE0190E: File not found: /web

The following error message is displayed when you try to access the rootservices document for JRS:


Error 500: java.lang.NoSuchMethodError.

Cause

The path to the Jazz Reporting Service shared libraries directory is incorrectly configured in IBM WebSphere Application Server (WAS).

Resolving The Problem

To correct the path to JRS shared libraries:

  1. Open WebSphere Administrative Console in a web browser.

  2. Expand Environment section.

  3. Click on Shared Libraries.

  4. Click on JRS Shared Library.

  5. Update Classpath field with the correct path to JRS shared libraries:
    <JRS Installation Directory>/server/conf/rs/WAS_SharedLibrary

  6. Click OK.

  7. Click Save directly to the master configuration.

  8. Restart the WebSphere Application Server.

If you do not see JRS Shared Library in step 4 above then perform steps 5 to 7 from the below link:
IBM Knowledge Center: Setting up the application server


If you are still seeing issues then please review the steps in the following to confirm you have completed them all with particular reference to step 10.
Deploying Jazz Reporting Service on WebSphere Application Server

[{"Product":{"code":"SSTU9C","label":"Jazz Reporting Service"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.0;6.0.1;5.0.1;5.0.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21713659