IBM Support

Sentinel RMS License Manager Server Usage Logging on Windows Operating Systems

Question & Answer


Question

How to determine if (a) usage logging is activated for License Managers installed on Windows OS and (b) if so, the name and location of the usage log and (c) if not, how to activate usage logging.

Cause

Usage logging is not automatically configured by the Sentinel License Manager software.

Answer

(A)
(1) Open Control Panel.
(2) Open System.
(3) Open Advanced System Settings.
(4) Select the 'Advanced' tab.
(5) Select 'Environment Variables' button.
(6) Is 'LSERVOPTS' included in the list of variable in the 'System Environment' pane?

If 'No' then go to (B).
If 'Yes' then go to (C).

(B)
(1) Select 'New' button.


(2) Variable name = LSERVOPTS
(3a) Variable value = -l "<drive and path where log file is to be saved>\slm_log.txt"
(3b) Note: the 'l' entry indicated in '-l' is lowercase letter 'L' not uppercase letter 'i'.
(3c) Note: Double-quotation marks enclosing the path statement and log file name are required.
(3d) Note: Do not use a network-connected drive in the path statement.
(4) Select 'OK' button.
(5) Check with your operating system documentation to determine if updating System Environment variables require a system restart to take effect:

If a system restart is NOT required, then go to (F).
If a system restart IS required, then restart the system and go to (G).

(C)
(1) Select the 'Edit' button.
(2) Determine if the entry with the indicated format is included in the contents of the 'Variable value' for LSERVOPTS:

-l "<drive and path where log file is to be saved>\<log file name>"

If an '-l' entry is NOT included in the contents of the 'Variable value' dialog box, then go to (D).
If an '-l' entry IS included in the contents of the 'Variable value' dialog box, then go to (E).

(D)
(1a) At the end of the 'Variable value' text box contents, add the following entry:

-l "<drive and path where log file is to be saved>\slm_log.txt"

(1b) Note: the 'l' entry indicated in '-l' is lowercase letter 'L' not uppercase letter 'i'.
(1c) Note: Double quotation marks enclosing the path statement and log file name are required.
(1d) Note: Do not use a network-connected drive in the path statement.


(2) Select 'OK' button.
(3) Check with your operating system documentation to determine if updating System Environment variables require a system restart to take effect:

If a system restart is not required, then go to (F).
If a system restart is required, the restart the system and go to (G).

(E)
(1) Note the drive, directory and file name indicated between the double quotation marks (") following the '-l' option.
(2) Navigate to the drive and directory indicated between the double quotation marks (") following the '-l' option.
(3) A file should exist with file name indicated between the double quotation marks (") following the '-l' option.
(4) This is the License Manager usage log file.
(5) Go to (H).

(F)
(1) Stop the 'Sentinel RMS License Manager' Windows Service.
(2a) Start the 'Sentinel RMS License Manager' Windows Service.
(2b) Note: Do NOT use the 'Restart' Windows Service option.

(G)
(1) Navigate to the location given in the '-l' option of LSERVOPTS System Environment variable.
(2) The log file indicated an 'slm_log.txt' file should now exist.
(3) Got to (H).

(H)
For processing the usage log see the following technical document: https://www.ibm.com/support/pages/node/284519

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Document Information

Modified date:
03 March 2022

UID

swg21701609