IBM Support

IBM Spectrum Protect for Workstations Central Administration Console SSL email certification

Troubleshooting


Problem

When the SSL email certificate needs to be updated on your IBM Spectrum Protect for Workstations Central Administration Console, you first need to remove the original certificate.

Symptom

Attempting to use the -add that is documented in the users guide will result in a message: email.cert was not successfully added to keystore.

Cause

The original email certification needs to be removed before a new one can be added.

Resolving The Problem

Tip: Beginning with Version 7.1.3, Tivoli Storage Manager FastBack for Workstations is now IBM Spectrum Protect for Workstations. Some applications such as the software fulfillment systems and IBM License Metric Tool use the new product name. However, the software and its product documentation continue to use the Tivoli Storage Manager product name. To learn more about the rebranding transition, see http://www.ibm.com/support/docview.wss?uid=swg21963634.

Install IBM Spectrum Protect for Workstations Central Administration Console 7.1.1.8 or later version.

Download the new certificate from the email server. Method is dependent upon the Server.

Save the certificate into a file named email.cert including the ----BEGIN CERTIFICATE----- to ----END CERTIFICATE-----.



Copy the file created 'email.cert' into the FBFWCAServer directory. This directory is located in the CAC install directory with the following path /CAC/wlp/user/servers/FBFWCAServer.
This is the default install location: C:\Program Files\Tivoli\TSM\CAC\wlp\usr\servers\FBFWCAServer

After the file is in that directory, open another command prompt and cd to the same directory:
C:\Program Files\Tivoli\TSM\CAC\wlp\usr\servers\FBFWCAServer

If a certificate has been previously imported or an error results indicating that the 'alias mykey' is already present run the following command:
"%CAC_INSTALL_DIR%\java\jre\bin\java" -cp fbfwca.jar com.tivoli.fbfw.ca.backend.security.CaSecurity -remove
Should see a confirmation in the command window: "Removed email SSL certificate successfully"

In that directory, run the following command:
"%CAC_INSTALL_DIR%\java\jre\bin\java" -cp fbfwca.jar com.tivoli.fbfw.ca.backend.security.CaSecurity -add
Should see a confirmation in the command window: "email.cert was successfully added to keystore"

Restart the IBM Spectrum Protect for Workstations Central Administration Console service for the changes to take effect.

[{"Product":{"code":"SSER9E","label":"IBM Spectrum Protect for Workstations"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1.1;7.1.2;7.1.3;7.1.4","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21700993