IBM Support

Unable to the start IBM Cognos Content Database on Windows

Troubleshooting


Problem

When configuring Cognos Integration for Maximo, you may receive errors starting the IBM Cognos Content Database when using Derby.

Symptom

Unable to start the IBM Cognos Server from the configuration manager.

Cause

This is caused by the script that starts the Derby database, using 'cat' commands, which fail to run as they are not recognized Windows commands.

Diagnosing The Problem

Review the details windows from the start up of the IBM Cognos Content Database, you will see the following if you are experiencing this issue.


[ ERROR ] The IBM Cognos Content Database service is starting.
errorlevel 1 exit 1
The IBM Cognos Content Database service could not be started.

The service did not report an error.

More help is available by typing NET HELPMSG 3534.

'cat' is not recognized as an internal or external command,
operable program or batch file.

Resolving The Problem

To resolve this problem open the derby.bat from cognosroot/c8_64/bin and search for all instances of "cat" (there should be two). Replace the CAT command with TYPE (windows equivalent) and save the file. Your edits will look like the following.


if exist "%DERBY_CONFIG_DIR%"\derby.properties (type "%DERBY_CONFIG_DIR%"\derby.properties>> "%DERBY_CS_DIR%"\derby.properties )

and

if errorlevel 2 (if exist "%DERBY_LOG_DIR%\derby.log" (type "%DERBY_LOG_DIR%\derby.log") & goto exit1)

After making the above changes, attempt to start the IBM Cognos Content Database from the Cognos Configuration Manager again. This error should no longer appear.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Report Admin","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21700989