Troubleshooting
Problem
When opening a package in report studio or running a report, the following message occur: "Server returned an unrecognizable metadata response" or "Server returned an unrecognizable load response for report" This occur at random times while at other time the same report will open up fine in report studio
Symptom
Error windows when a report is open up in report studio:
"Server returned an unrecognizable metadata response"
or
"Server returned an unrecognizable load response for report"
Cause
Very slow network between app server and the content manager database server and query database server.
Environment
Windows 2008R2
Cognos 10.2.1 RTM
Diagnosing The Problem
Verify that server performance by running cclperf -m0x20000000 -d0x20000000 .... this return satisfactory read/write response.
From the app server do a ping -l 30000 contentstore-database-server and this return a 16ms lag (A good network shows <1ms response).
From the app server do a tracert contentstore-database-server and this shows 7 hops for the test with last 3 hops showing 15ms latency.
Resolving The Problem
* Increase in portal server administration the number of report service process (default=2 while max will be 2 X Number of CPU)
* Increase the queue time limit of the report service from default 240 to 360
* Increase the queue time limit of the metadata service from default 240 to 360
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Document Information
Modified date:
15 June 2018
UID
swg21700601