IBM Support

IIS Agent events not linked with correct service in Tivoli Business Service Manager

Troubleshooting


Problem

Events that the IIS agent evemts are not linked to the correct service by using the BSM_Identity field in the Tivoli Business Service Manager.

Cause

This problem occurs because of an error in the Omnibus rules file that defines the integration between the two products.

Environment

Windows, Unix, Linux

Resolving The Problem

To solve this problem, complete the following steps:
1. Copy the kq7.zip file to your Omnibus system.
2. Extract the kq7.zip file to access the kq7_tbsm.rules file.
3. Copy the kq7_tbsm.rules file to the following locations.
For windows, %OMNHOME%\probes\win32
For Unix/Linux, %CANDLEHOME%/probes/<arch>

4. Select Copy and Replace when you are prompted to replace the kq7_tbsm.rules file.
5. Restart the following services, refer to Omnibus documentation for details:
- NCO NONNATIVE Probe (NCOTivoliEifProbe)

Verification procedure :
1. Log on to the Tivoli Integrated Portal.
2. Change the view to All tasks.
3. Go to Availability > Events > Active Event List (AEL).
4. Locate events that occurred after the rules were updated.
5. Double-click the event that you had triggered.
6. Verify that the value for the BSM Identity property is correct (BSM Identity should be like "PC2323:Q7:SampleSite" where "PC2323" is a node name, "Q7" is product code and "SampleSite" is a web application name)
kq7.zipkq7.zip

[{"Product":{"code":"SSDKXQ","label":"Tivoli Composite Application Manager for Microsoft Applications"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Microsoft Internet Information Services Agent - 5724B97IS","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.3.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21700269