IBM Support

LAN-Free backup fails with ANS1312E (RC12)

Troubleshooting


Problem

A Data Protection for Oracle client running on Solaris runs a LAN-Free backup, which fails with the ANS1312E error. The same backup works over the LAN.

Symptom

The RMAN backup shows the following errors :

ORA-27030: skgfwrt: sbtwrite2 returned error
ORA-19511: Error received from media manager layer, error text:
ANS1312E (RC12) Server media mount not possible

The tdpoerror.log file shows the following errors :

<timestamp> ANS1312E Server media mount not possible
<timestamp> TID<xxxx> ==> ANS1312E (RC12) Server media mount not possible

Cause

Tape mount failure with on Tivoli Storage Manager server or storage agent

Diagnosing The Problem

Examine the Tivoli Storage Manager server activity log for messages logged at around the same time. For example, in this case, the following messages were logged :

ANR0408I Session 123 started for server MY_AGENT (Solaris SPARC ) (Tcp/Ip) for library sharing. (SESSION: 123)
ANR8337I LTO volume ABC123L3 mounted in drive DRIVEA (/dev/rmt0). (SESSION: 1234)
ANR8779E (Session: 456, Origin: MY_AGENT) Unable to open drive /dev/rmt/2st, error number= 5. (SESSION: 456)
ANR8468I LTO volume ABC123L3 dismounted from drive DRIVEA (/dev/rmt0) in library LTOLIB. (SESSION: 123)
ANR0530W Transaction failed for session 789 for node MY_DP_ORACLE (TDP Oracle SUN) - internal server error detected. (SESSION: 789)
ANR0514I Session 789 closed volume . (SESSION: 789)
ANR1404W (Session: 456, Origin: MY_AGENT) Scratch volume mount request denied - mount failed. (SESSION: 456)
ANR0525W (Session: 456, Origin: MY_AGENT) Transaction failed for session nnn for node MY_DP_ORACLE (TDP Oracle SUN) - storage media inaccessible. (SESSION: 456)

These errors were logged because the storage agent was unable to open the tape drive for the LAN-Free backup due to the following error :

ANR8779E (Session: 456, Origin: MY_AGENT) Unable to open drive /dev/rmt/2st, error number= 5. (SESSION: 456)

In the above message, the storage agent tried to open tape drive device /dev/rmt/2st and received "error number= 5" from Solaris. This "error number= 5" means "I/O error". Following this error, the LAN-Free backup fails.

Resolving The Problem

The problem is with the tape device (/dev/rmt/2st) on the Solaris machine that runs the storage agent. An I/O error is logged when the storage agent tries to open tape drive.
In this case, since IBM tape drives are used, you should use the IBM Tape Diagnostic Tool (ITDT) to verify the tape device. From the Fix Central site, select the following :

  • From "Product Group", select "System Storage"
  • From "Select from System Storage", select "Tape systems"
  • From "Select from Tape systems", select "Tape drivers and software"
  • From "Select from Tape drivers and software", select "IBM Tape Diagnostic Tool ITDT"
  • From "Platform", select the appropriate operating system.
Then, download the corresponding "itdtinst***" file and extract.

Once the itdt command is extracted, run the following itdt commands to verify the device :

itdt -f /dev/rmt/2st inquiry
itdt -f /dev/rmt/2st inquiry 80
itdt -f /dev/rmt/2st devinfo

If any of these commands fail, it indicates that this /dev/rmt/2st device is not operational on this Solaris machine. You should try to remove and redefine the device on the Solaris machine. Check the
zoning for the tape drive and make sure it is configured correctly. Until the drive is operational again on Solaris, you should also consider updating the path to offline for this drive and storage agent to prevent the LAN-Free backup from using the drive.

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Document Information

Modified date:
17 June 2018

UID

swg21699292