IBM Support

Installing DB2 on Windows 2012 R2 nothing happens

Troubleshooting


Problem

The attempt to install a DB2 on Windows 2012 R2 fails - installation screen appears without left side menu.

Symptom

If 'setup.exe' is double-clicked on in Windows explorer, installation screen appears without left side menu like: "Welcome", "Release information", "Install a Product", "Exit" and there is no possibility to continue installation.

Cause

8.3 file name support is disabled by default on non system disk on Windows 2012, it is only enabled on system disk (C:\)

When there is space in the directory and 8.3 file name support is disabled, the launchpad can not work.

The DB2 image is located on non system disk in a path that contains spaces. For example:
"D:\db210.5 fp5"

Environment

Windows environment can have this issue

Resolving The Problem

Enable the 8.3 file name support on non system disk and copy the DB2 image again.

Or move the DB2 image to a new location - one that doesn't contain any spaces.

For example:

"D:\db210.5fp5"

[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Install\/Migrate\/Upgrade - Install\/Setup - GUI","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1;10.5;9.7","Edition":"Advanced Enterprise Server;Advanced Workgroup Server;Enterprise Server;Workgroup Server","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21699149