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How do I configure the StoredIQ Appstack to use authenticated users for sending SMTP email notifications?

Question & Answer


Question

How do I configure the StoredIQ Appstack to use authenticated users for sending SMTP email notifications?

Cause

The StoredIQ Appstack configuration requires that the username and password be blank for the default configuration in order to send email notifications from the Appstack

Answer

In order to use an authenticated user with the StoredIQ Appstack configuration you must provide authority in Exchange and Active Directory.

While it is possible to use the default SMTP Receive Connector it is recommended that a custom SMTP Receive Connector be created and configured to work with the StoredIQ Appstack. If a custom SMTP Receive Connector is created and defined with the specific IP address of the StoredIQ Appstack, network traffic from the Appstack will utilize that connector.

To create a custom SMTP Receive Connector follow these steps:

  1. In the Exchange Management Console navigate to the Server Configuration, Hub Transport section
  2. Select 'New Receive Connector...' from the menu on the right side
  3. Provide a name for the new SMTP Receive Connector and select 'Next'
  4. You may utilize the default port of 25. If you define another port be sure it is open on the Firewall of the Exchange
  5. Provide the Fully Qualified Domain Name (FQDN) of the Exchange Server in the field and select 'Next'
  6. On the Remote Network settings page select 'Add..' and enter the IP address of the StoredIQ Appstack and select 'OK'
  7. Select the IP address range of 0.0.0.0-255.255.255.255 and select the Red 'X' to delete it and then select 'Next'
  8. Review the configuration details and select 'New' to create the new custom SMTP Receive Connector

Once this has been done there are two methods that can be employed to authenticate users.

Method one: If you wish to configure the StoredIQ Appstack to authenticate on any existing domain user you should follow these steps:
  1. Log into your Exchange server
  2. Launch ADSI Edit
  3. In ADSI Edit navigate to CN=Configuration<domain>, CN=Services, CN=First Organization, CN=Administrative Groups, CN=Exchange Administrative Group, CN=Servers, CN=<Exchange Server>, CN=Protocols, CN=SMTP, CN=SMTP Receive Connectors
  4. Right click the custom SMTP Receive Connector you have created in the previous step. If you are using the default SMTP Receive Connector select that.
  5. Select the 'Security' tab
  6. In the upper section highlight 'Authenticated Users'
  7. In the Permissions section below select 'Allow' for the 'Accept any Sender' and the 'Accept Authoritative Domain Sender' options
  8. Select 'OK'

Method two: If you wish to configure the StoredIQ Appstack to authenticate with a single specific domain user and no other user, you should follow these steps:
  1. Log into your Exchange server
  2. Launch ADSI Edit
  3. In ADSI Edit navigate to CN=Configuration<domain>, CN=Services, CN=First Organization, CN=Administrative Groups, CN=Exchange Administrative Group, CN=Servers, CN=<Exchange Server>, CN=Protocols, CN=SMTP, CN=SMTP Receive Connectors
  4. Right click the custom SMTP Receive Connector you have created in the previous step. If you are using the default SMTP Receive Connector select that.
  5. Select the 'Security' tab
  6. In the upper section select the 'Add...' button
  7. Identify the single specific user you wish to allow authentication permissions for and select 'OK'
  8. In the upper 'Group or user names:' section identify the newly added user and highlight it
  9. In the Permissions section below select 'Allow' for the 'Accept any Sender' and the 'Accept Authoritative Domain Sender' options
  10. Select 'OK'

To configure the StoredIQ Appstack:
  1. Log in as root and launch the Appstack Configuration utility by executing the command /siq/bin/appstackcfg
  2. Provide the fully qualified hostname or short hostname for the Appstack in the Domain name field
  3. Provide the IP address for the StoredIQ Gateway server
  4. Provide the fully qualified hostname or IP address of the Exchange server
  5. Select the default Port of 25 or modify it to suit the port of your custom SMTP Receive Connector
  6. Provide the username of the user you wish to authenticate into the Exchange server with.
    1. If you used Method one above you may use any user name and password as long as they are a member of the domain
    2. If you used Method two, you must use only the user name of the single user you have granted permissions for
  7. Enter the password for the user selected in the previous step
  8. Select 'Enable TLS'
  9. Select 'Restart appstack services' (an alternative to this is to restart the Appstack services from the command line)
  10. Select 'Save and exit'
  11. Wait for all StoredIQ services to restart

You should now be able to send email notifications from the StoredIQ Appstack when generating reports or when using the eDiscovery Matter Dashboard.

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Document Information

Modified date:
17 December 2020

UID

swg21697645