IBM Support

SiteProtector Sensor Controller debug logging

Technote (FAQ)


Question

How do you collect SiteProtector Sensor Controller debug logging from the SiteProtector Console?

Cause

SiteProtector Sensor Controller logging may be used for various troubleshooting purposes, including but not limited to, SiteProtector components' status as Not Responding or Unknown, when the SiteProtector Sensor Controller service fails to start, problems with policy pushes for legacy agents, and certain SecureSync issues.

Answer

Follow these instructions to generate and collect the logs:

Enable Sensor Controller debug logging

  1. In the SiteProtector Console, go to Tools > System Logs > Set Server Logging Level...

  2. For the Sensor Controller Service, change the drop-down to DEBUG and click OK.
  3. You should now receive a pop-up box saying that the logging level for the Sensor Controller has been set to DEBUG as shown in the screen capture below.


Clean up the temp directory so only the newest logs are shown
  1. Stop the following services:
    SiteProtector Application Server Service
    SiteProtector Sensor Controller Service
    SiteProtector Web Server

  2. Browse to \Program Files\ISS\SiteProtector\Application Server and find the temp directory. Rename this directory to temp_old.
  3. Create a new temp directory. Be sure to use all lowercase characters. This resets the logs directory so we can see a clean set of logging.
  4. Start the following services:
    SiteProtector Application Server Service
    SiteProtector Sensor Controller Service
    SiteProtector Web Server


Re-create the issue and gather logging
  1. Re-create the issue or let the traces run until you see the behavior you are trying to catch in the logs.
  2. Once the issue has been replicated, add the new \Program Files\ISS\SiteProtector\Application Server\temp directory to a compressed file.


Return logging back to default level and send files to Support
  1. Repeat the first set of instructions, changing the logging level back to ERROR.
    Important: Failure to follow these steps results in very large log files that can lead to disk space issues on the system.
  2. Send the compressed file that contains the logs to Support by using Enhanced Customer Data Repository.



Related information

A Spanish translation is available

Document information

More support for: IBM Security SiteProtector System
Application Server

Software version: 3.0, 3.1.1

Operating system(s): Windows

Reference #: 1697052

Modified date: 27 April 2015


Translate this page: