IBM Support

MSSQL agents (oq) not collecting data, KOQCOLL.exe exits

Troubleshooting


Problem

SQL agent does not show data in TEP, collector process of the agent stops running.

Symptom

When MSSQL monitoring agent is started, it shows no data in Tivoli Enterprise Portal (TEP). Windows Task Manager shows that agent process (koqagent.exe) is running, but the collector process (koqcoll.exe) is not running.

Cause

Performance counters for the Microsoft SQL Server instance are not enabled.

Diagnosing The Problem

1) Collector log TMAITM6_x64\logs\*oq*.out has the following error:
UEX2492E (2014-12-27 19:37:50) KDDNTREG(5023) (1776)write_title_list(): SQL Server Instance performance data is not enabled!
KOS0001E (2014-12-27 19:37:50) KDDNTREG(610) (1776)Unable to write initialize file (null)
XXX0000W (2014-12-27 19:37:50) KDDNTREG(6030) (1776)Command cintmptlfl returned 4 -- quitting
ERSV106E (2014-12-27 19:37:50) KOQSQLD(4656) (1776)Failure during creation of perflib counter index file; rc = 4


2) <host>_regtitls.txt file is not generated in ITMHOME\TMAITM6_x64\logs (64 bit) or ITMHOME\TMAITM6\logs (32 bit) dirctory.

3) Open performance monitor (perfmon) application, select Performance Monitor tool. Click on Add (+) icon.

SQL Server performance counters are shown in the list of available counters.

The screen print shows counters for a default SQL Server instance.



If SQL Server counters are not present, then the performance counters need to be loaded for Microsoft SQL Server instance.

Resolving The Problem

If SQL Server performance counters are not loaded, then the collector process is unable to collect monitoring data, and exits.

Follow these steps to load SQL Server counters:

1) Unload counters by running unlodctr command.

For default instance:
unlodctr MSSQLSERVER

For named instance:


unlodctr MSSQL$<instance_name>




2) Find the ini file corresponding to the SQL Server instance:
To find the ini files for SQL Server instances, open a MS DOS command prompt. Go to directory <MSSQL Home>\MSSQL.n\MSSQL\Binn\ and run command:
dir *.ini

A list of ini files is displayed.

Following screenshot shows the ini file for default instance MSSQLSERVER.



3) Load performance counters for the monitored instance as shown below:

cd <MSSQL Home>\MSSQL.n\MSSQL\Binn

Run command:
lodctr perf-<instance_name>sqlctr.ini


Restart the MSSQL Server for the performance counters to take effect. Refer to MS SQL Server documentation for additional details.

Performance counters for SQL Server show up in the perfmon application.

Restart the monitoring agent.

[{"Product":{"code":"SSDKXQ","label":"Tivoli Composite Application Manager for Microsoft Applications"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.3.0;6.3.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21696752