IBM Support

Security Bulletin: Tivoli Storage Manager Stack-based Buffer Overflow Elevation of Privilege: CVE-2014-6184

Security Bulletin


Summary

A vulnerability in the IBM Tivoli Storage Manager (TSM) client could allow a local user to gain elevated privileges due to a stack-based buffer overflow.

Vulnerability Details

CVEID: CVE-2014-6184
DESCRIPTION:
IBM Tivoli Storage Manager is vulnerable to a stack buffer overflow. A local attacker could overflow a buffer and execute arbitrary code on the system with root privileges.

CVSS Base Score: 7.2
CVSS Temporal Score: See http://xforce.iss.net/xforce/xfdb/98520 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (AV:L/AC:L/Au:N/C:C/I:C/A:C )

Affected Products and Versions

  • TSM Client 6.3.0.0 through 6.3.2.2
  • TSM Client 6.2.0.0 through 6.2.5.3
  • TSM Client 6.1.0.0 through 6.1.5.6
  • TSM Client 5.5.0.0 through 5.5.4.3
  • TSM Client 5.4.0.0 through 5.4.3.6

Remediation/Fixes

TSM Release First Fixing VRMF Level Client
Platform
APAR Link to fix
6.3



6.3.2.3



AIX
HP-UX
Linux
Solaris
Mac
IT05707



http://www.ibm.com/support/docview.wss?uid=swg24037930



6.2 6.2.5.4 AIX
HP-UX
Linux
Solaris
Mac
IT05707 http://www.ibm.com/support/docview.wss?uid=swg24036287
6.1 6.1.5.7 AIX
HP-UX
Linux
Solaris
Mac
IT05707 Customers with support extensions on 6.1 should contact IBM Support.
5.5 5.5.4.4 AIX
HP-UX
Linux
Solaris
Mac
IT05707 Customers with support extensions on 5.5 should contact IBM Support.
5.4 5.4.3.7 AIX
HP-UX
Linux
Solaris
Mac
IT05707 Customers with support extensions on 5.4 should contact IBM Support.
6.3 B/A clients in 6.3 TSM for Space Management package 6.3.2.3 AIX
Linux x86

IT05707 http://www.ibm.com/support/docview.wss?uid=swg24038153
6.2 B/A clients in 6.2 TSM for Space Management package 6.2.5.4 AIX
Linux x86
IT05707 http://www.ibm.com/support/docview.wss?uid=swg24036287
6.1 B/A clients in 6.1 TSM for Space Management package 6.1.5.7 HP-UX
Solaris
IT05707 http://www.ibm.com/support/docview.wss?uid=swg24031758
6.1 B/A clients in 6.1 TSM for Space Management package none, beyond support AIX
Linux x86
Upgrade to fixing level or apply workaround.
5.5 and lower B/A clients and 5.5 and lower TSM Space Management none, beyond support AIX
Linux x86
HP-UX
Solaris
Upgrade to fixing level or apply workaround.

Workarounds and Mitigations

Remove the Trusted Communications Agent (TCA), module dsmtca, from the TSM client machine. This will disable all non root users from running the TSM Client.

Get Notified about Future Security Bulletins

References

Complete CVSS v2 Guide
On-line Calculator v2

Related information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

Acknowledgement

This vulnerability was reported by Matthias Kaiser from Daimler TSS GmbH

Change History

30 Jan 2015: Original text published
18 Feb 2015: Link to 6.2 fixes published
24 Feb 2015: CVSS Temporal Score xforce link corrected
26 Feb 2015: 6.1, 5.5, and 5.5 First Fixing VRMF Level added, links to TSM for Space Management packages with fixed Backup-Archive client added, Workaround updated.

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Cross reference information
Segment Product Component Platform Version Edition
Storage Management IBM System Storage Archive Manager AIX, HP-UX, Linux, Solaris, Mac OS 6.2, 6.3
Storage Management Tivoli Storage Manager Extended Edition AIX, HP-UX, Linux, Solaris, Mac OS 5.4, 5.5, 6.1, 6.2, 6.3

Document information

More support for: Tivoli Storage Manager
Client

Software version: 5.4, 5.5, 6.1, 6.2, 6.3

Operating system(s): AIX, HP-UX, Linux, Solaris, iOS

Reference #: 1695878

Modified date: 23 December 2016


Translate this page: