Troubleshooting
Problem
Trying to activate the database receives SQL1042C "An unexpected system error occurred." In the db2diag.log you notice errors like "Log file SXXXX.LOG on log stream X not found." and/or "Log extent is compressed."
Cause
The log file is not in the active log path or the log file in the active path is compressed.
Diagnosing The Problem
Find the missing log file and move to the active log path. If the missing log file is located in the archive directory and the database has log compression enabled, ie:
Archive compression for logarchmeth1 (LOGARCHCOMPR1) = ON
then you must first decompress the log file before moving to the active log path. If the logs are not decompressed before moving to the active path, you will notice messages like the following in the db2diag.log when database activation fails:
2015-01-28-10.16.43.262076-300 I2067165A472 LEVEL: Error
PID : 5767206 TID : 4893 PROC : db2sysc 0
INSTANCE: db2inst1 NODE : 000 DB : SAMPLE
HOSTNAME: db01
EDUID : 4893 EDUNAME: db2loggr (SAMPLE) 0
FUNCTION: DB2 UDB, data protection services,
sqlpgOpenAndVerifyOneRecoverableLogStream, probe:1480
MESSAGE : ZRC=0x071000EA=118489322=SQLPG_EXT_COMPRESSED
"Log extent is compressed."
Resolving The Problem
Once the missing log file is decompressed in the active path, try activating the database again. If you encounter more missing log files, repeat the steps above.
Note: DB2 LUW does not have external tools available to decompress log files. If you do not have software that can decompress the log files for you, please contact DB2 LUW Support for assistance.
Related Information
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Document Information
Modified date:
16 June 2018
UID
swg21695717