IBM Support

NDMP backup fails with ANR4728E error

Troubleshooting


Problem

An NDMP device is configured to back up to a Tivoli Storage Manager server. The backup fails with the following error : []ANR4728E Server connection to file server 127.0.0.1 failed.[]

Cause

Incorrect configuration

Diagnosing The Problem

In this case, the host name of the system that is running the Tivoli Storage Manager server is resolved to 127.0.0.1 instead of its actual dotted IP address. The correct dotted IP address must be used by the NDMP device to initiate a session with the Tivoli Storage Manager server when running the backup. Log on to the system that runs the Tivoli Storage Manager server and verify how the host name is resolved.
ping <hostname of machine>

The host name should resolve to the dotted IP address, not 127.0.0.1.

Resolving The Problem

Ensure that the host name of the Tivoli Storage Manager server resolves to the correct IP address. You can also use the NDMPPREFDATAINTERFACE option on the Tivoli Storage Manager server. This option specifies the address that the NDMP device must use to communicate with the Tivoli Storage Manager server. You can set this option dynamically with the following administrative command on the Tivoli Storage Manager server:
setopt NDMPPREFDATAINTERFACE <ipaddress>

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21695075