IBM Support

Unable to connect to the planning service

Troubleshooting


Problem

Performance modeler fails to open with "Unable to connect to the planning service"

Cause

Virus scanner blocking the application

Environment

10.1.1, 10.2, 10.2.2

Diagnosing The Problem

Logging used to identify the time out condition:

Navigate to the c:\users\<username>\Appdata\Roaming\IBM\Cognos Performance Modeler
Edit the default log properties file


Change log4j.rootLogger=ERROR, appAppender to log4j.rootLogger=DEBUG, appAppender
Save

Rename provagent_NOT.ini to provagent.ini
Edit provagent.ini
Remove the comment (#) for the app-debug=true \\ removing the comment enables the line
Save file

Edit cognosrcp.ini
Change log.level=none to log.level=debug

Generate the error by selecting Performance modeler icon from GUI
Once error occurs open the logs folder
Edit the ModelingMDT and provagent log file now created


Partial capture of the log with evidence of timeout and socket error:
java.net.ConnectException: Connection timed out: connect
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:412)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:271)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:258)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:376)
at java.net.Socket.connect(Socket.java:537)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
at java.lang.reflect.Method.invoke(Method.java:611)

Resolving The Problem

In this case Symantec Endpoint Protection virus scanner was blocking performance modeler from executing.

1. Double click on Symantec EndPoint Protection
2. Select status
3. Select Options for Network Threat Protection
4. Select "view application setting"
5. Locate the entry for performance modeler and allow by checking the box.
6. Test

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1 Performance Modeler","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1;10.2;10.2.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21694666