IBM Support

Unable to see transactions in the transaction log

Troubleshooting


Problem

The transaction log (tm1s.log) is not showing all data changes that are made in the cubes. The data changes are visible in the cubes but are missing in the log.

Cause

Cube logging is not turned on for some (or all) cubes.

Resolving The Problem

In Server Explorer, via either Architect or Perspectives, log into the TM1 server and do the following:
- Right-click on Cubes and choose Security Assignments

- In the Security Assignments window, find the intersection of the affected cube(s) and the Logging column and click in the box to enable the logging

- Click OK

- Test by entering some data in an affected cube and then right-click on the server name and choose to View Transaction Log to be sure that the entries are there. This can also be checked by stopping the TM1 server and then viewing the resulting tm1s<date/timestamp>.log file that is generated.

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.0;10.1.1;10.2;10.2.2;9.5;9.5.1;9.5.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21694653