IBM Support

"The 'OraOLEDB.Oracle.1' provider is not registered on the local machine" when testing database connection

Troubleshooting


Problem

Administrator launches "Controller Configuration". Administrator clicks on database connection, and clicks 'test'. An error appears. If the user tries to launch Controller, a similar error appears.

Symptom


The 'OraOLEDB.Oracle.1' provider is not registered on the local machine

Error launching Controller client:
The exact error will depend on the environment, for example:



System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Runtime.InteropServices.COMException: Provider cannot be found. It may not be properly installed.
at FrServerB.ServerInfoClass.GetDBRelease(String sGuid, String sUser)
at Cognos.Controller.Proxy.CCRWS.ServerInfo_GetDBRelease(String sGuid, String sUser)
--- End of inner exception stack trace ---

Cause

There are several possible causes for this message:

  • Scenario #1 - The Controller application server does not have the Oracle client(s) installed
  • Scenario #2 - The Controller application server has the Oracle client installed, but the relevant DLL ("OraOLEDB11.dll") is not registered correctly.

Environment

Controller database hosted on an Oracle 11G database server.

Resolving The Problem

Scenario #1 - The Controller application server does not have the Oracle client(s) installed

Install the Oracle client on the Controller application server.

  • If it is already installed, then uninstall/re-install it.

Steps (for Controller 10.2):

From Controller 10.2 onwards, both the Oracle 64-bit and 32-bit clients must be installed on the application server.

  • The following steps are based on Oracle 11G Rel2 and Controller 10.2:
  • o Download the latest patchset version of the Oracle 11G release 2 (rel2) 64-bit client. At the time of writing:

    o The latest version is 11.2.0.4 (Oracle patch 13390677)

    o This is available from here: https://updates.oracle.com/ARULink/PatchDetails/process_form?patch_num=13390677

    o Specifically, you need to select ‘Microsoft Windows x64 (64-bit)’. Then download the file “p13390677_112040_MSWIN-x86-64_4of7.zip”.

    NOTE: We have deliberately not chosen to download the original version (11.2.0.1) of the client (which is the file “win64_11gR2_client.zip”) because there are known Oracle bugs in this version.

    o Extract this file (p13390677_112040_MSWIN-x86-64_4of7.zip) onto the Controller application server, and run 'setup.exe'

    o VITAL: During the client installation wizard, select a full 'Administrator' install option:




    o TIP: After the install has finished, check that it has installed all the expected components, by looking at the size of the "C:\app" folder (or wherever you have installed it to). The total size should be approximately 1.05Gb.

    · Now create/edit your TNSNAMES.ORA file.

    o By default, this is located here: C:\app\Administrator\product\11.2.0\client_1\network\admin

    o Ensure that it contains entries on how to connect to your Oracle database server(s)

    · Next you need to create a ‘System Variable’ (on your Controller application server) called ‘TNS_ADMIN’ to point to the location of your TNSNAMES.ORA file.

    o By default, the value would be: C:\app\Administrator\product\11.2.0\client_1\network\admin




    o Download the latest patchset version of the Oracle 11G release 2 (rel2) 32-bit client. At the time of writing:

    o The latest version is 11.2.0.4 (Oracle patch 13390677)

    o This is available from here: https://updates.oracle.com/ARULink/PatchDetails/process_form?patch_num=13390677

    o Specifically, you need to select ‘Microsoft Windows (32-bit)’. Then download the file “p13390677_112040_WINNT_3of6.zip”.

    NOTE: We have deliberately not chosen to download the original version (11.2.0.1) of the client (which is the file “win32_11gR2_client.zip”) because there are known Oracle bugs in this version.

    o Extract this file (p13390677_112040_WINNT_3of6.zip) onto the Controller application server, and run 'setup.exe'

    o VITAL: During the client installation wizard, select a full 'Administrator' install option:




    · The author recommends that you install this software to a SEPARATE folder (from the 64-bit client)

    o For example, install it into the folder: C:\app_32\Administrator

    · After the install has finished, check that it has installed all the expected components, by looking at the size of the "C:\app_32" folder (or wherever you have installed it to). The total size should be approximately 1.05Gb.



Scenario #2 - The Controller application server has the Oracle client installed, but the relevant DLL is not registered correctly.
Register the file "OraOLEDB11.dll".

Steps:
The following steps are based on Controller 10.2, using a 64-bit Oracle client installed into the default location.
They may need to be modified slightly for your environment.
    1. Launch a Command Prompt (CMD) as the user 'Administrator'
    2. Type the following command
      CD C:\APP\Administrator\product\11.2.0\client_1\BIN

    3. Type the following commend:
      c:\Windows\system32\regsvr32.exe OraOLEDB11.dll

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21694296