IBM Support

"ANR9010W Unable to verify drive" because of a serial number mismatch

Troubleshooting


Problem

A mount operation request may fail with the following error logged in the Actlog: ANR9010W Unable to verify drive \\.\tape0

Symptom

The following errors may be logged in the Tivoli Storage Manager Activity Log (also known as Actlog) during a mount request activity as for a restore from Client:


<timestamp> ANR9010W Unable to verify drive \\.\tape0. (SESSION: 123) <timestamp> ANR8381E LTO volume 12345DL5 could not be mounted in drive DRIVE1 (\\.\tape0). (SESSION: 123)
<timestamp> ANR1401W Mount request denied for volume 12345DL5 - mount failed. (SESSION: 123)
<timestamp> ANR0542W Retrieve or restore failed for session 123 for node VCI (??) - storage media inaccessible. (SESSION: 123)

Cause

A "PVR MMS ADDMSG" Server trace will show a "serial number mismatch" problem on all drive in the library, for example:

<timestamp> [50][mmsdrive.c][8413][MmsCheckTapeId]:Xinquiry was
successful for drive DRIVE1; opened with path \\.\tape0 serial
[1068072924], wwn [2004000E1114E61B], and vendor [IBM].
<timestamp> [50][mmsdrive.c][8421][MmsCheckTapeId]:Serial number
mismatch! The serial in descriptor is [1068073647], and the serial for
inquiry is [1068072924] for drive DRIVE1
<timestamp> [50][pspvr.c][3610][PvrPsCloseDevice]:Device with handle
00000000000111CC is closed
<timestamp> [50][pspvr.c][3622][PvrPsCloseDevice]:Removing device
\\.\tape0 with handle 70092 from devList

<timestamp> [50][mmsdrive.c][8421][MmsCheckTapeId]:Serial number
mismatch! The serial in descriptor is [1068073647], and the serial for
inquiry is [1068072924] for drive DRIVE1
..
<timestamp> [50][mmsdrive.c][8609][MmsCheckTapeId]:Returning from
MmsCheckTapeId for drive DRIVE1 with rc = 4098.

From the trace extract, we see that the server had drive "DRIVE1" defined with a serial number.
When the server connects to the drive it always will verify the serial number.
In this case, the server detects that it does not match with the previously recorded serial number.
This might occur if the system is rebooted and the Operating System does not assign the same device name to the same drive.

Diagnosing The Problem

Collect a Tivoli Storage Manager Server trace from the Administrative Command Line (dsmadmc) by using the following steps:

trace disable *
trace enable pvr mms addmsg
trace begin <traceoutfile>
---> recreate failure and wait for error to occur
trace flush
trace end
trace disable *

Resolving The Problem

SAN discovery is an option that might help avoid this situation. Below is a link with information on SAN discovery.
Proceed with the following steps:

- Stop the Tivoli Storage Manager Server by "halt" command
- Edit the file dsmserv.opt for your Server instance and insert the following option:
SANDISCOVERY ON
- Save the file and restart the Tivoli Storage Manager Server

Related Information

[{"Product":{"code":"SSSQWC","label":"Tivoli Storage Manager Extended Edition"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21694082