IBM Support

ANS1796I code 305 error during filesystem Windows Bare Metal Restore

Technote (troubleshooting)


Problem(Abstract)

After a Windows system state restore during Bare Metal Restore, the remaining filesystem restore shows error ANS1796I because 8dot3 is not activated.

Symptom

Filesystem restore fails with the following message displayed in the dsmerror.log:

ANS1796I The short name for '<filename>' could not be set to original short name '<short_filename>': Windows function 'SetFileShortName' failed with return code 305, reason: 'Short names are not enabled on this volume.'


Cause

During a backup the ASR writer reports metadata describing all the disks and volumes on the system. Tivoli Storage Manager Client stores this metadata in a XML document (ASRBackupDoc.xml) and then sends it to the Tivoli Storage Manager Server as part of a system state backup.
This document contains detailed information about the disks and volumes but it does not have information whether 8dot3 is enabled or not.
During the restore, the Tivoli Storage Manager Client passes the same metadata (stored in ASRBackupDoc.xml) back to the ASR writer which recreates the disks and volumes as necessary.
The activity is done in the Pre-Restore phase of the restore sequence and the disks are formatted using default values.
By default the 8dot3 feature is disabled.


Environment

Tivoli Storage Manager client on Windows platform

Diagnosing the problem

During the system state recovery, the disk partitions are not recreated with the same configuration.

The 8.3 NTFS short names feature is disabled on the recovered partitions.


Resolving the problem

To enable 8.3 name creation on all NTFS partitions, type the Windows command : fsutil.exe.

Set disable8dot3 "0" at the elevated command prompt, and then press Enter.
Re-run the filesystem restore.


Cross reference information
Segment Product Component Platform Version Edition
Storage Management Tivoli Storage Manager Client Windows

Document information

More support for: IBM Spectrum Protect
Client

Software version: All Supported Versions

Operating system(s): Windows

Software edition: All Editions

Reference #: 1693943

Modified date: 27 December 2016


Translate this page: