IBM Support

WebSphere Application Server 8.5.5 may not start when using Java 7 after upgrading to fix pack 2 or later, with APAR PM97140

Troubleshooting


Problem

After upgrading WebSphere to 8.5.5 fix pack 2 or above, if a server is using Java 7 and the optional Java 7 service release is not also updated (as recommended), WebSphere will fail to start.

Symptom

WebSphere fails to start after upgrade and native_stderr.log has the following error message:

JVMJ9VM007E Command-line option unrecognised: -Xcheck:dump
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Cause

APAR PM97140 introduced -Xcheck:dump to the application server arguments which requires a minimum of Java 7 SR4.

Resolving The Problem

Upgrade the optional Java 7 to the recommended version to match the WAS upgrade: https://www-304.ibm.com/support/docview.wss?uid=swg27005002

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Install","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF012","label":"IBM i"},{"code":"PF016","label":"Linux"}],"Version":"8.5.5.4;8.5.5.3;8.5.5.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21692797