IBM Support

Agent configuration does not discover MSSQL instance

Troubleshooting


Problem

ITCAM agent for Microsoft SQL server does not discover SQL server instance during configuration.

Symptom

When you configure the agent instance using MSSQL monitoring agent template in Manage Tivoli Enterprise Monitoring Services (MTEMS), no SQL Server instances are shown in "Configure Database Agents" configuration dialog.

Cause

The cause may be one of the following:
1) The version of MSSQL Server is not supported by the installed monitoring agent version.
2) The user running MTEMS does not have sufficient privileges to the SQL server instance on the host system.

Environment

Windows

Resolving The Problem

1) Make sure that the monitoring agent version supports the MSSQL Server version that is to be monitored. You can do this by generating a compatibility report using following link:
http://www.ibm.com/software/reports/compatibility/clarity/index.html

If the report shows that the installed monitoring agent version does not support the MSSQL Server version, then install the agent release which does support it.


2) Close the Manage Tivoli Enterprise Monitoring Services (MTEMS) GUI and then start it using 'Run as administrator' option as shown in the screen print below.                                

Try configuring the agent instance again, the SQL Server instance(s) is now discovered.

[{"Product":{"code":"SSDKXQ","label":"Tivoli Composite Application Manager for Microsoft Applications"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Microsoft SQL Server Agent - 5724B96MO","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.3.0;6.3.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21692150