Troubleshooting
Problem
User imports data (into Controller) via a flat-file (for example CSV). Afterwards, the "Statistics - Import of External Data" window shows a very large number of 'DiscardedRows'. User double-clicks on the entry (to open the report). Inside the report, there are a large number of errors.
These errors will only occur where the values (to be imported) are not whole numbers (integers) - instead, they contain a decimal point.
Symptom
1016 The value must be numeric
Cause
There are several possible causes for the same symptom/error
- TIP: See separate IBM Technote #6221264 for more examples.
This Technote specifically relates to the scenario where the cause is a limitation of Controller, triggered if the regional settings decimal symbol is a comma.
More Information:
When using Controller (for example seen with version 10.2), the Controller application server's regional settings must be configured to be a compatible setting (for example 'English (UK)').
Environment
As an example, the problem has been seen when the Controller application server's regional settings are set to Czech.
NOTE: The South African regional settings are actually compatible for Windows 2008 (and earlier) because there was a change (by Microsoft) for the South African regional settings from Windows 2012 onwards. See Windows article (at the end of this Technote) for more details.
It has also been seen when both of the following are true:
- Controller application server based on Windows 2012
- Regional settings set to South African.
NOTE: The South African regional settings are actually compatible for Windows 2008 (and earlier) because there was a change (by Microsoft) for the South African regional settings from Windows 2012 onwards. See Windows article (at the end of this Technote) for more details.
Resolving The Problem
Modify the Controller application server's regional settings to be a compatible setting (for example 'English (UK)').
Steps:
1. Obtain a short period of downtime (no users on the system)
2. Logon to the Controller application server as an administrator
3. Launch Control Panel
4. Open 'Region'
5. Change "Format" to "English (United Kingdom)":
6. Click tab 'Location'
7. For the sake of consistency, change this to 'United Kingdom' too
8. Click tab "Administrative"
9. Click "Change system locale..." and change this to "English (United Kingdom)":
10. Click "Copy Settings"
11. Tick the box "Welcome screen and system accounts"
12. Tick "New user accounts":
13. Click OK
14. Reboot the Controller application server
15. Test.
Steps:
1. Obtain a short period of downtime (no users on the system)
2. Logon to the Controller application server as an administrator
3. Launch Control Panel
4. Open 'Region'
5. Change "Format" to "English (United Kingdom)":
6. Click tab 'Location'
7. For the sake of consistency, change this to 'United Kingdom' too
8. Click tab "Administrative"
9. Click "Change system locale..." and change this to "English (United Kingdom)":
10. Click "Copy Settings"
11. Tick the box "Welcome screen and system accounts"
12. Tick "New user accounts":
13. Click OK
14. Reboot the Controller application server
15. Test.
Related Information
[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
09 June 2020
UID
swg21691867