IBM Support

Setting a big session time-out value in DASH causes session lock-out

Troubleshooting


Problem

Using a big value (2147483647) for the session timeout setting in DASH, to achieve the maximum time between timeouts, is causing users to be locked out completely.

Symptom

After entering the user ID and password in the login page, and then pressing the "continue" button,
the login page does not change, stuck at "processing" and then returns to the login page again."

All users get essentially locked out completely from DASH sessions.

Cause

In order to maximize the time between session timeouts, the customer is setting the timeout parameter in the security.xml file to 2147483647.

This timeout parameter used in the security.xml file is a WAS setting, but DASH is using a javascript call (settimeout), which causes a condition that prevents a login, if the timeout value is really big.

Note: 2147483647 is the maximum positive value for a 32-bit signed binary integer in computing.

Resolving The Problem

This condition that prevents logins can be averted by setting the custom property LTPAFIX in the consoleProperties.xml to "false".

Please follow this steps:

1. On DASH server, navigate to <JazzSM Home>/profile/config/cells/JazzSMNode01Cell/applications/isc.ear/deployments/isc/isclite.war/WEB-INF


2. Take a backup of consoleProperties.xml


3. Open consoleProperties.xml in edit-mode.


4. Search for "LTPAFIX" and change the value from "true" to "false".

Example:

Before
=====
<consoleproperties:console-property id="LTPAFIX" value="true"/>
</consoleproperties:ibm-portal-consoleproperties>

After
====
<consoleproperties:console-property id="LTPAFIX" value="false"/>
</consoleproperties:ibm-portal-consoleproperties>

5. Save the file.


6. Restart DASH server.

[{"Product":{"code":"SSRLR8","label":"Tivoli Components"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"1.1.1","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
17 June 2018

UID

swg21690658