IBM Support

Security Bulletin: Vulnerability in SSLv3 affects IBM Connections (CVE-2014-3566)

Security Bulletin


Summary

SSLv3 contains a vulnerability that has been referred to as the Padding Oracle On Downgraded Legacy Encryption (POODLE) attack, which is a man-in-the-middle attack affecting Web browsers. IBM Connections utilizes IBM WebSphere Application Server and IBM HTTP Server which enable SSLv3 by default.

Vulnerability Details

CVE ID: CVE-2014-3566
DESCRIPTION: IBM WebSphere Application could allow a remote attacker to obtain sensitive information, caused by a design error when using the SSLv3 protocol. A remote user with the ability to conduct a man-in-the-middle attack could exploit this vulnerability via a POODLE (Padding Oracle On Downgraded Legacy Encryption) attack to decrypt SSL sessions and access the plaintext of encrypted connections.

CVSS Base Score: 4.3
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/97013 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (AV:N/AC:M/Au:N/C:P/I:N/A:N)

Affected Products and Versions

The following versions of IBM Connections are impacted:

IBM Connections 5.0
IBM Connections 4.5
IBM Connections 4.0
IBM Connections 3.0.1.1 and earlier releases

Remediation/Fixes

IBM Connections is remediated via an IBM WebSphere Application Server APAR; apply the appropriate WAS APAR as per this table. Note, these interim fixes apply an IBM JDK enhancement specifc to the WAS Fix Pack listed. Also, if possible, it is always recommended to upgrade to the most recent release of IBM Connections.

Product Version Remediation
IBM Connections 5.0 Upgrade to IBM Connections 5.0 CR1 and WAS Fix Pack 8.5.5.2; then apply WAS APAR PI28920
IBM Connections 4.5 Upgrade to IBM Connections 4.5 CR5 and WAS Fix Pack 8.0.0.8; then apply WAS APAR PI29575
IBM Connections 4.0 Upgrade to IBM Connections 4.0 CR4 and WAS Fix Pack 7.0.0.35; then apply WAS APAR PI28439
IBM Connections 3.0.1.1 Upgrade to IBM Connections 3.0.1.1 CR3 and WAS Fix Pack 7.0.0.35; then apply WAS APAR PI28439
IBM Connections 3.0.1 and earlier releases Either upgrade to IBM Connections 5.0 CR1 and WAS Fix Pack 8.5.5.2; then apply WAS APAR PI28920 or upgrade to IBM Connections 3.0.1.1 CR3 and WAS Fix Pack 7.0.0.35; then apply WAS APAR PI28439

Workarounds and Mitigations

None

Get Notified about Future Security Bulletins

References

Complete CVSS v2 Guide
On-line Calculator v2

Related information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Document information

More support for: IBM Connections

Software version: 3.0, 3.0.1.1, 4.0, 4.5, 5.0

Operating system(s): AIX, Linux, Windows

Reference #: 1690640

Modified date: 18 November 2014


Translate this page: