IBM Support

Email reply is not working for changing status of SR

Troubleshooting


Problem

When replying to email to change status the following error occurs. Unable to process your email. BMXAA8434E - The first line of the body of the email or the LSNR_ROUTE_ACTION line is empty. Verify that the communication template is properly formatted and contains the required identifiers.

Cause

The person record Email Format field is set to 2 - Advanced and customer is replying using simple format.

Diagnosing The Problem

You may receive emails that look something like this


1. This email example is a simple format email. In this case you can just simply reply to email using 1 or 2.

You have a workflow assignment in the SR application, on record Class
SR, Service Request 1000 .
This is for approval of software Office 2013 requested by Maximo Administrator
.
1 - Accept Request
2 - Reject Request
.
#MAXIMO_EXT_MAIL_BEGIN
#@ The contents of this section are used by the system to identify the
#@ workflow. This section should not be modified while replying to the
#@ email. The system text must be in its exact original form to process
#@ correctly.
_________________________________________________________
;
LSNRIDVALUE=XXXXXXXXXXXXXXXXXXXXXXXXXXXXX
;
LSNRAPPLIESTO=SR
;
WFASSIGNMENTID=5555
;
_________________________________________________________
#MAXIMO_EXT_MAIL_END
.
2. This email example below is advanced and uses a formatted email. If you are updating multiple fields you must use this method. You must reply using the xml or value pairs format of the email format below. See LSNR_ROUTE_ACTION= requires you to reply with the value 1 or 2. If you reply to this email with just 1 or 2 you will receive the error.

BMXAA8434E - The first line of the body of the email or the LSNR_ROUTE_ACTION line is empty. Verify that the communication template is properly formatted and contains the required identifiers.


.
You have a workflow assignment in the SR application, on record Class
SR, Service Request 1000 .
This is for approval of software Office 2013 requested by Maxadmin
.
#MAXIMO_EXT_MAIL_BEGIN
LSNR_ROUTE_ACTION=
#@ To indicate how you want to complete the task, reply with one of the
#@ following numbers as the first line of this email.
#@ 1 - Accept Request
#@ 2 - Reject Request
;
_________________________________________________________
;
LSNRIDVALUE=XXXXXXXXXXXXXXXXXXXXXXXXX
;
LSNRAPPLIESTO=SR
;
WFASSIGNMENTID=5555
;
_________________________________________________________
;
#MAXIMO_EXT_MAIL_END

Resolving The Problem

There are 2 potential solutions to this problem.
1. You can update the Person record EMail Format field to 1 - Simple format if you are doing one action.

or


2. You can reply to the email using a formatted email and supply the action(s). If you will be updating multiple field you must use this method and use a formatted template.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"E-Mail Listener Config","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.5;7.6","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21690021