IBM Support

Attempts to submit multiple IBM Developer for z/OS CARMA jobs fail with EDC8128I error

Troubleshooting


Problem

Attempts to start multiple IBM Developer for z/OS (IDz) CARMA jobs may fail with the error "EDC8128I" while using batch submit.

Symptom

CARMA jobs fail because of timeout, with error:
 
CRASERV: connect: EDC8128I Connection refused. (errno2=0x76630291)

Cause

The jobs that are submitted by IDz for CARMA Endevor using the batch submit, CRASUBMT, all have the same jobname of CRA, instead of CRA+the port number that is being used for the submit, and therefore JES queues up the jobs to run, and they may timeout while waiting.

Environment

z/OS

Diagnosing The Problem

If you are using CRASUBMT, which is found in FEK.#CUST.CNTL, then you should check that the jobname and the first parameter in the CLIST are using the same variable name.

For instance, the job below needs to be changed because the first parameter passed is different than the variable name used in the jobname:

PROC 8 CRAPRM1 CRAPRM2 CRAPRM3 CRAPRM4 CRAPRM5 CRAPRM6 CRAPRM7 CRAPRM8
SUBMIT * END($$)
//CRA&PORT JOB CLASS=A,MSGCLASS=A,MSGLEVEL=(1,1)

 

Resolving The Problem

Change the jobname variable in CRASUBMT to match the name of the first variable in the CLIST.

In the example above, the jobname should be changed to be //CRA&CRAPRM1.

[{"Type":"MASTER","Line of Business":{"code":"LOB35","label":"Mainframe SW"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSTRMM","label":"IBM Developer for z\/OS"},"ARM Category":[{"code":"a8m0z00000009ErAAI","label":"IBM Developer for Z\/OS-\u003ECARMA Endevor"}],"ARM Case Number":"","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"All Versions"}]

Product Synonym

IDz

Document Information

Modified date:
26 November 2023

UID

swg21689523