IBM Support

Upgrade 6.2 to 7.1 fails with error "table or view does not exist".

Troubleshooting


Problem

When upgrading Maximo 6.2 to 7.1 on Oracle, the upgrade can fail with the error: SQL Error: ORA-00942: table or view does not exist

Symptom

Upgrade utility fails in script V600_09. End of the upgrade log shows:

-- For details of patch V600_09, see logfile : ConfigDBnnnnnnnnnnnn.log
java.sql.SQLException: ORA-00942: table or view does not exist

End of ConfigDB shows additional information:

Rebuilding table CONTRACTLEASE
ORA-00942: table or view does not exist
BMXAA6819I - ConfigDB completed with errors.

Cause

Insufficient privileges on Oracle view user_tab_privs.

Environment

Windows, Oracle, Maximo 6.2 upgrading to 7.1.

Diagnosing The Problem

Run this query on the database. If the query fails with the same ORA-00942 error, then the problem is that the user is unable to query from Oracle view user_tab_privs; the view lacks sufficient privileges.

Select * From user_tab_privs Where table_name = 'CONTRACTLEASE' Order By grantee ;

Resolving The Problem

Privileges need to be granted to query Oracle view user_tab_privs.

- Restore the database to pre-upgrade 6.2.
- Connect to the database as user SYS and run this SQL:
Grant select on user_tab_privs to public ;
- Verify the same SQL select now runs without error:
Select * From user_tab_privs Where table_name = 'CONTRACTLEASE' Order By grantee ;
- Start the upgrade utility over again.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":"Upgrade Utility","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.2;6.2.8;7.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSLKTY","label":"Maximo Asset Management for IT"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSKTXT","label":"Tivoli Change and Configuration Management Database"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SS6HJK","label":"Tivoli Service Request Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21688737