IBM Support

Security Bulletin: POODLE vulnerability in SSLv3 affects IBM Explorer for z/OS and IBM CICS Explorer (CVE-2014-3566)

Security Bulletin


Summary

SSLv3 contains a vulnerability that has been referred to as the Padding Oracle On Downgraded Legacy Encryption (POODLE) attack. This vulnerability affects all versions of IBM Explorer for z/OS and IBM CICS Explorer.

Vulnerability Details

CVE ID: CVE-2014-3566

DESCRIPTION: IBM Explorer for z/OS and IBM CICS Explorer could allow a remote attacker to obtain sensitive information, caused by a design error when using the SSLv3 protocol. A remote user with the ability to conduct a man-in-the-middle attack could exploit this vulnerability by using a POODLE (Padding Oracle On Downgraded Legacy Encryption) attack to decrypt SSL sessions and access the plaintext of encrypted connections.

CVSS Base Score: 4.3
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/97013 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (AV:N/AC:M/Au:N/C:P/I:N/A:N)

Affected Products and Versions

This vulnerability affects all versions of IBM Explorer for z/OS and IBM CICS Explorer.

Workarounds and Mitigations

From CICS Explorer 5.1 onwards, do the following to set your secure protocol preference manually:

  1. From the CICS Explorer menu, select Window > Preferences > Explorer > Certificate management
  2. Set your protocol to a value other than SSLv3 or default (which would allow the server to negotiate SSLv3).

This setting affects both CICSplex SM Data Interface connections and CICS management client interface (CMCI) connections.

For other connections that are made from within the Explorer product and that use SSL, for instance the Eclipse update site functions, if your server is configured to use SSLv3 then CICS Explorer will continue to use SSLv3. Therefore, you should disable SSLv3 in the configuration of any servers that CICS Explorer is configured to connect to.

Update 12 December 2014:
IBM is providing fix packs with a newer Java™ Runtime Environment (JRE) that does not allow the SSLv3 protocol. Fix packs for the POODLE security vulnerability are provided by the following APARs for the various supported releases of the CICS Explorer and IBM Explorer for z/OS (z/OS Explorer):
Product APAR
Version / Fix Pack
Description of Fix
CICS Explorer
1.0.0.9
Update for POODLE security vulnerability
1.0.1.4
1.1.0.4
1.1.1.5
5.1.0.2
5.1.1.6
5.2.0.2
z/OS Explorer
2.1.0.8


In addition to the APARs for the POODLE security vulnerability, the following APARs are included in the CICS Explorer 5.2.0.2 and z/OS Explorer 2.1.0.8 Fix Packs:
Product APAR
Version / Fix Pack
Description of Fix
CICS Explorer
5.2.0.2
Update for POODLE security vulnerability
Maintenance roll up
In CICS Explorer 5.2.0.1 programs appear with a 'BUNDLE' icon
Support for MAC OS X Yosemite 10.10
z/OS Explorer
2.1.0.8
Update for POODLE security vulnerability
Maintenance roll up
Support for MAC OS X Yosemite 10.10

Get Notified about Future Security Bulletins

Important note

IBM strongly suggests that all System z customers be subscribed to the System z Security Portal to receive the latest critical System z security and integrity service. If you are not subscribed, see the instructions on the System z Security web site. Security and integrity APARs and associated fixes will be posted to this portal. IBM suggests reviewing the CVSS scores and applying all security or integrity fixes as soon as possible to minimize any potential risk.

References

Complete CVSS v2 Guide
On-line Calculator v2

Related information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.


Cross reference information
Segment Product Component Platform Version Edition
Host Transaction Processing IBM Explorer for z/OS Security All Editions

Product Alias/Synonym

CICS/TS CICS TS CICS Transaction Server

Document information

More support for: CICS Transaction Server
Explorer

Software version: 3.1, 3.2, 4.1, 4.2, 5.1, 5.2

Operating system(s): Windows, z/OS

Reference #: 1687988

Modified date: 15 December 2014


Translate this page: