IBM Support

The Service Name you have chosen already exists

Troubleshooting


Problem

When creating a new instance on a Windows machine using the Server Instance Manager, you receive the following error message: Invalid Service Name: The Service Name you have chosen already exists. It could be in use by other Informix products. Choose a different value.

Cause

When creating a new instance on a Windows machine using the Server Instance Manager, if it fails for any reason, you must check to see if any new entries in the registries and the services file need to be manually removed before attempting to reinstall.

Resolving The Problem

For Windows, you will need to look in the '%WINDIR%\system32\drivers\etc\services' directory and search for the Service Name entry affiliated with the instance you are attempting to create.
If one exists, either remove or comment out the line in the services file.

Next, ensure the registry entries are cleaned up, start in the 'HKEY_LOCAL_MACHINE\SOFTWARE\Informix' directory then check in SQLHOSTS, Online, etc.. for new entries affiliated with the instance you are attempting to create and remove any related entries.


After ensuring these have been removed, the instance should successfully be created, however if the Server Instance Manager fails to complete again for any reason, you will need to repeat this process to ensure new registry and services file entries have been cleaned up before re-attempting to create the instance.

[{"Product":{"code":"SSGU8G","label":"Informix Servers"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.5;11.7;12.1","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
29 September 2018

UID

swg21687313