IBM Support

Help for applying a Fix Pack or interim fix for IBM Cognos Business Intelligence

Question & Answer


Question

How to apply Fix Pack / interim fix or Hotsite for IBM Cognos Business Intelligence ?

Cause

There are times when you have to implement a Fix Pack or an Interim Fix (also referred as Hotsite) for your IBM Cognos BI installation. The following steps are to assist with a smooth upgrade.

Answer


Planning:

1. Prepare a test case of the things that you will test after the installation. Any issues experienced prior to adding a fix pack should also be included in your test case.
2. Test those things and screen capture the results. This forms your Fix Pack post-installation test case.
3. Download the fix pack for both server and client components. For example, 64-bit server components you must download the 64-bit Fix Pack version. Client components, such as Framework Manager, you must download the 32-bit Fix Pack components. To confirm if the component is 32-bit or 64-bit you can analyze the cmplst file from your installation.
3. Apply the fix on a test server. Only after successful testing, apply the fix to a production or development server. This is very important for Interim Fixes as limited testing has been done in the area that they fix.
5. Also, read any specific instructions that are related to the fix pack you are applying, on the download URL.
In the case of an interim fix, refer to the release notes. Accordingly, for example, if the Interim Fix is to be applied only to particular components only, it will be mentioned in the release notes and you need to act .

Installation Steps on the Server:
1. Stop services on the web server (IIS/IBM HTTP Server/Apache WebServer) so that no one can access Cognos URL.
2. Stop IBM Cognos service on all servers in this order.
Application Server then Content Manager.

If you have multiple application server, stop all the Application Server one after the other and then proceed with Content Manager.

If you have a Stand By Content Manager, make sure that is the services on StandBy Content Manager is stopped before Active Content Manager.

3. Make sure that there are no Stale processes related to Cognos (java.exe, BiBusTkServerMain.exe, cgslauncher.exe, cogbootstrap.exe etc.) in Task Manager or server. If they exist, you must stop them explicitly.

4. Take backup of complete Cognos Installation directory on all the servers.
5. Take backup of Content Store database - Database level backup. This is more of a database administratords task.
6. Move all the content(files and folders) in the Logs and Temp folder outside Cognos Installation Directory. In other words, the Logs and the Temp directory should be empty.

Caution: - Do not delete the Logs and Temp directory. If you get error that it is not able to empty the Logs or Temp directory it indicates that Cognos Configuration can be open on one of the systems.

7. Apply fix pack/Interim Fix. When prompted, click yes to execute a backup as it is a specific backup of the files that will be changed and will provide a rollback if required.

9. This step is only required if you are using application server other then Default like Websphere or Oracle Weblogic. You need to rebuild and redeploy ear/war file.

9. Start IBM Cognos services. In the case of Distributed environments, first start the Cognos Service on Content Manager machine followed by StandBy Content Manager(if applicable) and then on all Application Server.
10. Start the services of web server, which we stopped in Step(1).
11. Run through the test cases you prepared in your planning stage. In other words test the issue for which the Fix was provided.

Fixpack or interim fix Installation on Client Component: -
1. Apply Fix Packs on client components(Framework Manager) as well.
Before applying the fix pack take backup of the installation folder and project content available on the client component. Test the client component as well using the test case prepared in the planning phase.

If after applying the fixpack you determine a rollback is required, use the following instructions
http://www-01.ibm.com/support/docview.wss?uid=swg21341204

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2.1;10.2.1.1;10.2.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21686885