IBM Support

Delete A Storeroom

Question & Answer


Question

Is it possible to delete a Storeroom?

Cause

A Storeroom might not be needed anymore, or has physically changed or merged.

Answer

A Storeroom can be deleted if there has never been items or tools added to it. This also means that no inventory transactions have been conducted for this storeroom.

You can delete a storeroom record by using the Delete Storeroom entry on the Select Action menu in the Storerooms application only under the condition that no items or tools have ever been added to this Storeroom. One of the reasons that Maximo only allows deletion under this condition is to thoroughly preserve the data integrity of the feature, which allows items to have statuses. This was not available in previous versions of Maximo.

From a database standpoint, even if the item or tool records are set to "obsolete" status, they still hold a relationship to the inventory table. (as history records)

Recommended Methodology to Make a Storeroom Inactive

Several conditions need to be met regarding the items that currently exist in the Storeroom in order to properly remove the Storeroom from use by non-admin Users.

-In the Storeroom record, uncheck the box for "Use in PO/PR?". This ensures that the Storeroom cannot be used for internal PO/PRs.

-You can remove access to it by modifying any Security Groups, which either have specific access to this Storeroom, or by modifying any Security Groups which have the "Access To All Storerooms" privilege.

-For Security Groups that have access to all Storerooms:
a. In the Security Group application, open the record for the Security Group and go to the
Storerooms tab
b. Un-check the box for "Authorize Group for All Storerooms?" and then add the desired
Storerooms via the New Row button; Save the record.

-For Security Groups which have specific access to the Storeroom:
a. Delete the row for that Storeroom and Save the record.

Make the Storeroom's Items Obsolete

-Each item must have no balance; balances can be transferred to another storeroom via the Inventory Usage application, or can be issued through normal business operations until the quantity reaches zero.

-Each item must be changed to OBSOLETE status; the items must not be used on any open/pending transactions such as PR, PO, SRs, Desktop Requisitions, or be associated with active Work Orders or Job Plans:
Note that the item status must first be changed to Pending Obsolescence, and then the item status must be changed to Obsolete.

-Close, process, or otherwise complete all open Purchase Requisitions, Service Requests, Desktop Requisitions, and Purchase Orders that have PR/MR/PO Lines for any item in the Storeroom.

-Close or edit all open Work Orders which have material reservations for any item in the Storeroom (advanced search for the Storeroom in the Work Order application will indicate the items)

-Edit all Active Job Plans that have material reservations for any item in the Storeroom (advanced search for the Storeroom in the Work Order application).

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Document Information

Modified date:
20 January 2023

UID

swg21685517