IBM Support

ANR0522W and "ANS1329S Server out of data storage space" during client backup

Troubleshooting


Problem

When backing up data to a storage pool (FILE or DISK), it may fail even though there is sufficient space available in the storage pool as well as in the next (sequential) storage pool.

Symptom

In the Tivoli Storage Manager server actlog:
ANR0522W Transaction failed for session <sesssion#> for node NODE1 (<platform>) - no space available in storage pool <stgpool name> and all successor pools.

In the Tivoli Storage Manager client errorlog:
ANS1329S Server out of data storage space

Cause

When a client session has to wait for a mount point , either because no volumes (scratch or pre-defined) are available or there a no mount points left, it will be set to wait for a specific volume.
If that volume gets filled up by another session or process, the Tivoli Storage Manager does not have a recovery method at that point.
The way this case is handled is that the Tivoli Storage Manager server reports to the client, that he does not have the space. Therefore the client administrator needs to manually restart the request.

In the special case of a FILE pool where disk space is a limiting factor, there may be no possibility of adding scratch volumes.

If the server can define scratch volumes but does not have any mount points left on the device class it will also fail with the message:

ANR0535W Transaction failed for session session number for node node name (client platform) - insufficient mount points available to satisfy the request.

If possible, make more mount points available in the device class configuration.

This problem is seen for an almost full (sequential) storage pool as well as for a pool that has enough space available.

If the storage pool gets full while a backup/archive operation is running, it will fail with the same error, even if there is a next pool with sufficient space available.

Only if the storage pool is completely full such that there are no remaining volumes available and there are no empty or filling volumes in the pool then the initial allocation would go directly to the next storage pool.

Spanned volumes can also be a problem because the Tivoli Storage Manager does not allow a bitfile to span storage pools.

Diagnosing The Problem

When client backups are running, the following might occur:

- All volumes belonging to the FILE storage pool are mounted
- No scratch nor pre-defined file volume can be used, because there are no unused volume available
- As explained above, the server selects one volume for the backup sessions to wait for
- But when this volume becomes full, the waiting will fail
- Since the wait for the volume failed, the massage ANR0522W is thrown
- The server will not try to wait for an other volume

Resolving The Problem

- Add more pre-defined volumes.
- Allow the server to define scratch volumes.
- Use MAXSIZE parameter to force larger objects to nextstgpool.

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Document Information

Modified date:
17 June 2018

UID

swg21684682