IBM Support

Collecting Data: IBM Connections Profiles

Technote (troubleshooting)


Problem

Your IBM® Connections Profiles application requires troubleshooting, the following document will help to determine what data to collect for troubleshooting purposes.

Cause

Gathering this information before calling IBM support will reduce the time that it takes to understand and resolve your problem.

Resolving the problem

Data collection:

Collecting the following data before contacting support will help expedite problem determination and resolution of the problem:

Files to collect
Collecting the following data before contacting support will help expedite problem determination and resolution of the problem: 

1. Provide a precise description of the issue, error message, steps to reproduce, browser version 
and relevant environment setup (e.g. WAS/IBM Connections release, CR and ifixes, LDAP type and version, SSO?, Proxy?)

2. Provide support a compressed copy of the logs directory %WAS_HOME%/profiles/appSrv01/logs (trace.log, systemout.log, systemerr.log and FFDC logs) from the node.

3. Collect the following files that store properties that control common Lotus Connections features:
Located in directory %WAS_HOME%\profiles\(your profile)\config\cells\(your cell)\LotusConnections-config
LotusConnections-config.xml
profiles-config.xml
profiles-types.xml
profiles-policy.xml
widgets-config.xml
wimconfig.xml
Proxy-config.tpl
Proxy-profiles-config.tpl If available
Notifications-config.xml This is a file to collect if e-mail notifications are not working in one or more components
\profiles\ If there is a problem with email notifications also send the FreeMarker template files in this subdirectory.


Profiles Tracing:
Support may instruct to enable tracing and provide a tracing data set for analysis. The following are instructions on how to implement Lotus Profiles Tracing:

1. Log on to the WebSphere Application Server (WAS) integrated solutions console using an administrator ID
2. Go to Troubleshooting -> Logs and Trace -> Logging and Tracing -> Server 1 (or server Bookmarks is installed on) -> Diagnostic Trace Server -> Change Log Detail Levels -> please add the following *string and click Apply -> OK

Tracing Strings:

Login Issues (Waltz trace):
*=info: com.ibm.websphere.wim.*=all: com.ibm.ws.wim.*=all:com.ibm.connections.directory.services*=all

Database Issues:
*=info:
com.ibm.lconn.*=finest:com.ibm.connections.*=finest:
com.ibatis.common.jdbc.SimpleDataSource=finest:
com.ibatis.common.jdbc.ScriptRunner=finest:
com.ibatis.sqlmap.engine.impl.SqlMapClientDelegate=finest:
java.sql.Connection=finest:java.sql.Statement=finest:
java.sql.PreparedStatement=finest:com.ibm.peoplepages.internal.service.*=finest:
com.ibm.lconn.profiles.internal.service.*=finest:
com.ibm.connections.directory.services.*=all:
com.ibm.lconn.events.internal.*=all:
com.ibm.websphere.wim.*=all:
com.ibm.ws.wim.*=all:
com.ibm.connections.httpClient.*=all:
com.ibm.lconn.profiles.internal.jobs.*=all:
com.ibm.lconn.profiles.internal.*=all:
com.ibm.lconn.core.compint.profiles.internal.policy.*=all

Profiles Search:
*=info: com.ibm.peoplepages.internal.service.cache.*=all:com.ibm.lotus.connections.dashboard.search.searchInterface.*=all

Widgets:
*=info:com.ibm.lconn.widgets.*=all:com.ibm.lconn.extdatamodel.*=all:com.ibm.connections.httpClient.*=all

3. Reproduce the problem and send support a compressed copy of the logs directory %WAS_HOME%/profiles/appSrv01/logs (trace.log, systemout.log, systemerr.log and FFDC logs) from the node where the profiles application is installed.

Collect a Fiddler Trace
Fiddler is a tool for monitoring requests made and received by a web browser. This information is often invaluable when troubleshooting a problem with IBM Connections. Due to the AJAX nature Connections, an error message may not always display the true cause of the error. A fiddler trace helps all requests or responses that may have been made.

Fiddler can be downloaded from http://www.fiddler2.com

Close all other browser windows before opening fiddler, log into connections. Run the fiddler application. Have the user perform the operation that is causing the error. When the action has been completed, save the results in fiddler by choosing “File”->”Save”->”All Sessions”.


Please configure fiddler to decrypt the https request:
Select "Decrypt HTTP traffic" and ""Ignore server Certificate errors



For TDI (Tivoli Directory Integrator) related issues,
Trace Strings:
Please enable all of the following fields in the TDISOL\profiles_tdi.properties file:
source_ldap_debug=true
tds_changelog_debug=true
sync_updates_clean_temp_files= false

In the \tdisol\TDI\etc\log4j.properties file:

look for
log4j.rootCategory=INFO, Default 

change it to 
log4j.rootCategory=DEBUG, Default

Data is to be collected after sync has run. Please review ibmdi.log to verify that the sync has completed prior to collecting the data for support.


Provide the following files, logs and traces:
Located under the %TDI_HOME%\TISOL directory:
map_dbrepos_to_source.properties 
map_dbrepos_from_source.properties
profiles_tdi.xml
profiles_tdi.properties
ibmdi.log 
populateDBfromDNfile.log
ProcessTDSChanges.log 
ProcessADChanges.log 
MonitorDraftUpdates.log

SyncUpdates.log
Collect.dns

Document information

More support for: IBM Connections
Profiles

Software version: 5.0, 5.5, 6.0

Operating system(s): AIX, Linux, Windows

Software edition: All Editions

Reference #: 1683775

Modified date: 01 October 2015


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