IBM Support

archecker table level restore failing in BSAGetObject() with XBSA return code 17 or 3 because of missing INFORMIXSERVERNUM information

Troubleshooting


Problem

Why does a table level restore attempt with archecker fail with CRITICAL ERROR: Unable to locate object. BSAGetObject failed with 17 (No match) or STATUS: Staging Log 123 ERROR: Unable to locate object. BSAGetObject failed with 3 (System error)

Cause

Depending on the storage manager that is used the Informix server number may need to be announced for the successful reception of the storage manager objects. The return code 17 was for example observed when using the HP Data Protector client. The return code 3 was returned by Symantec Netbackup.

Resolving The Problem

Setting the environment variable INFORMIXSERVERNUM to the server number of the Informix instance on which the referred backup was taken may allow the archecker operation to continue.

Please note that there may be other reasons why an object in the storage manager cannot be found.

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Document Information

Modified date:
16 June 2018

UID

swg21683377