IBM Support

Error -27001 received when attempting to connect to IDS with OAT

Troubleshooting


Problem

After installing OAT, running the StartApache script and attempting a new connection with OAT, you receive the following error: Connection Failed: -27001 [Informix][Informix ODBC Driver][Informix]Read error occurred during connection attempt.

Cause

The -27001 error on the client side can occur for several reasons, the most common are:

1) The server or network is very busy, causing the connection attempt to time-out

2) The server is off-line during the connection attempt

3) OAT is trying to connect to an incorrect port number

Resolving The Problem

In the cases where the network is busy or the server is offline, ensuring the server is in online mode and retrying the connection will generally resolve the error, however setting the environment variable INFORMIXCONRETRY to a higher value can also be helpful on a busy server/network.

In the case that OAT is connecting to an incorrect port number, it is necessary to review the services file on the server side to see what port number IDS is listening on.

Then, on the OAT 'Edit a Connection' menu, ensure that the value entered in the 'Port' field is the port number that IDS is listening on. Also ensure that the 'idsd port' field is left blank. The idsd daemon should only be used to enable starting a server in a high-availability cluster or adding a shared disk secondary (SDS) server.

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Document Information

Modified date:
29 September 2018

UID

swg21682638