IBM Support

Internal Server Error while exporting to snapshot in TM1 Web

Troubleshooting


Problem

Choosing the option to Snapshot to Excel in TM1Web, the following error message is displayed: "Internal Server Error".

Symptom

Error message is displayed "Internal Server Error".

Cause

When a sheet is converted from Excel to the web, TM1 reads from Excel where the end of the actively used spreadsheet is.  The command CTRL+END in Excel moves the active cell to the end of the report.  Sometimes Excel sets the active area of the spreadsheet much larger than is actually used.  This causes the TM1Web to then convert many empty rows and columns, leading to unnecessary memory requirements.

Environment

Tested on (but can apply to other configurations and versions):
Windows Server 2008 R2 SP1, English
Internet Explorer 9 (Build 9.0.8112.16421)
TM1 Web 10.2.2, Build Number 10.2.20000.50183
Excel 2010 version 14.0.4760.1000 64 bits

Resolving The Problem

A common best practice is to highlight and delete all columns to the right of the area used in a spreadsheet and all rows below the area used, then re-uploading the spreadsheet.  This typically will correct the problem if the web is converting empty columns or rows.

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1 Web","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
13 February 2020

UID

swg21682360