Troubleshooting
Problem
User is logged in as the 'root' Admin and is unable to start the License Manger process (LSERV) on a RedHat 6.4 Server.
Symptom
When running the ./lserv command to start the License Manager process you see the following:
[root@sfo-spss License_Manager]# ./lserv
Sentinel RMS Development Kit 8.2.3.400 License Management Server
Copyright (C) 2009 SafeNet, Inc.
Initializing. Please wait ...
SentinelLM: gethostbyname:: Success
[root@sfo-spss License_Manager]#
You should see:
Initializing. Please wait ...
Running on host [localhost]
[root@sfo-spss License_Manager]#
Cause
Does the /etc/hosts file have an entry for this server's IP and hostname? Or is just the loopback device defined?
-- It might be that the server cannot 'recognize itself' and the LM may have bound itself to the loopback device. Thus "./lsmon localhost" might succeed where "./lsmon <IP Address>" fails.
[OTHER Possibilities]
1) If a firewall exists between client and LM server, open port 5093 UDP on that firewall.
2) Is the license file ('lservrc') located in the LM installation directory? or is it someplace else?
- -- If you've moved the license file, you will need to tell the LM where to find it:
Instead of starting the LM with just "./lserv"
Start it with "./lserv -s <path and license file name>"
Environment
Linux
RedHat
Diagnosing The Problem
From a command line in the LM WinNT directory run:
ps -ef | grep lserv
Do you see "lserv"?
If lserv is not found, the process is not running.
Resolving The Problem
Edit /etc/hosts and add a line that defines the server by hostname and IP.
Related Information
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Document Information
Modified date:
16 April 2020
UID
swg21682158