IBM Support

TWS v9.2 installation fails on Windows 2012 server

Troubleshooting


Problem

AWSJIM253E error occurs during the database configuration step: AWSJIM253E: Database access denied. Or database service is not running. Specify the correct information to connect to the database and verify that the database service is up and running.

Symptom

<message>executing command: ""D:\Program Files\IBM\SQLLIB"\bin\db2cmd /c
/i db2level"</message>
</entry>
<entry num='793' time='1406241643215' elapsed='04:32.33' level='INFO'
thread='main'>
<logger>com.ibm.tws.im.Util</logger>
<class>com.ibm.cic.agent.internal.core.IMLoggerImpl</class>
<method>info</method>
<message>result of the command: 0</message>
</entry>
<entry num='794' time='1406241643231' elapsed='04:32.35' level='INFO'
thread='main'>
<logger>com.ibm.tws.im.Util</logger>
<class>com.ibm.cic.agent.internal.core.IMLoggerImpl</class>
<method>info</method>
<message>command output: </message>
</entry>
<entry num='795' time='1406241643231' elapsed='04:32.35' level='ERROR'
thread='main'>
<logger>com.ibm.tws.im.db.Db2EnterpriseWin</logger>
<class>com.ibm.cic.agent.internal.core.IMLoggerImpl</class>
<method>error</method>
<message>ERROR getting DB2 version, setting the minimum supported:
9.1.0.0</message>
</entry>
<entry num='796' time='1406241643231' elapsed='04:32.35' level='INFO'
thread='main'>
<logger>com.ibm.tws.im.db.Db2EnterpriseWin</logger>
<class>com.ibm.cic.agent.internal.core.IMLoggerImpl</class>
<method>info</method>
<message>the DB2 version to be validated is 9.1.0.0</message>
</entry>
<entry num='797' time='1406241643231' elapsed='04:32.35' level='INFO'
thread='main'>
<logger>com.ibm.tws.im.db.Db2EnterpriseWin</logger>
<class>com.ibm.cic.agent.internal.core.IMLoggerImpl</class>
<method>info</method>
<message>the minimum DB2 supported version is 9.7.0.0</message>

Cause

8dot3 is not enabled on the drive where you are attempting to install Tivoli Workload Scheduler (TWS).

Environment

*Windows 2012 server (and possibly other versions of the Windows operating system)
* Installing on the D: drive as Active Directory domain user
* db2stop and db2start work correctly

Diagnosing The Problem

Check the 8dot3 setting:

fsutil behavior query disable8dot3 <DRIVE> (ie C:)

If you see the following message then 8dot3 is disabled:

The volume state for Disable8dot3 is 1 (8dot3 name creation is disabled).
The registry state of NtfsDisable8dot3NameCreation is 2, the default (Volume level setting).

Resolving The Problem

Apply the resolution from the following DB2 Technote, then attempt the TWS installation again:

http://www-01.ibm.com/support/docview.wss?uid=swg21665716

[{"Product":{"code":"SSGSPN","label":"IBM Workload Scheduler"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.1;9.2;9.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

Maestro;IWS;TWS;TWA

Document Information

Modified date:
17 June 2018

UID

swg21681253