IBM Support

SiteProtector X-Press Update Server manual debug logs

Question & Answer


Question

How do you manually generate debug logs for SiteProtector's X-Press Update Server component?

Cause

The SiteProtector X-Press Update Server (XUS) is responsible for downloading updates for the SiteProtector components. If an issue with the download occurs and the XUS is not communicating with SiteProtector, IBM Support might require manual debug X-Press Update Server logging to investigate the problem.

Important: If the XUS shows an Active status in SiteProtector, these instructions should not be used. Instead, you should use the instructions in Technote 1697055: SiteProtector X-Press Update Server debug logging .

Answer

Follow these instructions to generate and collect the logs:
  1. Download the udrc.zip file that is attached to this article.

    udrc.zipudrc.zip
  2. Extract the file that is named .udrc into the following directory on the XUS server:

    \Program Files\ISS\SiteProtector\Application Server\webserver\IHS\

    Note: The Windows operating system does not allow users to create a file name starting with a period. Because of this, Support provides the .udrc file to customers in a compressed file. Users should not attempt to rename the file because the operating system will not allow it to be changed back to its original form that begins with a period.
  3. Locate the following file and open it with a text editor:

    \Program Files\ISS\SiteProtector\Application Server\webserver\IHS\conf\UpdateServer.xml
  4. Find the line that looks like:

    <Logging level='ERROR'>

    And change it to:

    <Logging level='DEBUG'>

    Note: The original version of the line may have a value other than ERROR, depending on modifications that previous users have made to the system.
  5. Open Windows Services and restart the SiteProtector Web Server service.
  6. With logging now enabled, gather the relevant data by doing the following:
    1. On the Application Server machine, restart the SiteProtector Sensor Controller service in Windows Services. This will briefly cause the SiteProtector components to go to an "Unknown" status, which is expected. This will force SiteProtector to attempt to download a new update catalog file.
    2. If an XPU is failing to download, try to perform the XPU download again.
    3. Wait 5 minutes to make sure you get a full capture of the logs.
  7. Add the following files to a single compressed file:

    \Program Files\ISS\SiteProtector\Application Server\webserver\IHS\htdocs\XPU\UpdateServer.log
    \Program Files\ISS\SiteProtector\Application Server\webserver\IHS\conf\*.xml
    \Program Files\ISS\SiteProtector\Application Server\webserver\IHS\.udout
  8. Delete the .udrc file and revert the changes made in Steps 3 and 4.
  9. Restart the following services:

    SiteProtector Web Server
    SiteProtector Sensor Controller Service

    Important: Failure to follow Steps 8 and 9 will result in large log files. This can lead to disk space issues on the system.
  10. Send the compressed file containing the logs to Support using Enhanced Customer Data Repository (ECuRep) .

[{"Product":{"code":"SSETBF","label":"IBM Security SiteProtector System"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Xpress Update Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.0;3.1.1","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
14 April 2021

UID

swg21681064