Troubleshooting
Problem
User launches Controller. User receives error.
Symptom
Error Contacting User Manager.
Error Details:
System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Runtime.InteropServices.COMException (0x80070424): Retrieving the COM class factory for component with CLSID {BE913F44-118C-11D5-A324-00C04FA0E3B7} failed due to the following error: 80070424.
at FrLicServerProxy.LicServerProxy.GetCurrUsers()
at FrUserManagerB.LocalUserManager.GetCurrentUsers(String sGuid, String sUser)
at FrUserManagerB.UserManagerB.GetCurrentUsers(String sGuid, String sUser)
at Cognos.Controller.Proxy.CCRWS.UserManager_GetCurrentUsers(String sGuid, String sUser)
--- End of inner exception stack trace ---
Cause
There are several possible causes for similar symptoms.
- See separate IBM Technotes for further possibilities.
This IBM Technote specifically relates to the scenario where the cause is that the Windows service 'IBM Cognos Controller User Manager' does not exist on the Controller application server.
Diagnosing The Problem
Open the Windows Services, and notice how "IBM Cognos Controller User Manager" does not exist:
Resolving The Problem
The solution depends on the environment:
- Sometimes, simply rebooting the application server once again will fix the problem
- If this does not solve the problem then it is possible to manually create the Windows service "IBM Cognos Controller User Manager".
Steps:
1. Reboot the Controller application server.
- If this fails to solve the problem, go to step 2.
2. Logon to the Controller application server as a Windows administrator
3. Launch a command prompt (START - RUN - "CMD" <Enter>)
4. Type the following command:
sc create frLicServer binpath= "C:\Program Files\ibm\cognos\ccr_64\server\FrLicServer.exe" DisplayName= "IBM Cognos Controller User Manager" depend= RpcSs start= auto
NOTE:
- The above command assumes that you are using Controller 10.2.0, installed into the default location, on Windows 2012 R2
- Naturally the command parameters may have to be modified slightly depending on your environment (for example if you have installed the software into a different location).
5. Reboot the Controller application server
6. Test.
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21680788