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DB2 API backups failing with Reason Code 106

Troubleshooting


Problem

DB2 API backups to Tivoli Storage Manager Fail with SQL2033N RC 106

Symptom

Example output:

db2 backup db sample online use tsm

SQL2033N An error occurred while accessing TSM during the processing of a database utility. TSM reason code: "106"

Cause

RC 106 translates to 'Access to the specified file or directory is denied', and it is typically reported when the instance owner does not have write permissions to the directory and/or file name of the API error log. The default directory is /usr/tivoli/tsm/client/api/bin or bin64, depending on the bit level of the DB2 instance. Non-AIX platforms use /opt instead of /usr. The default file name is dsierror.log.

Diagnosing The Problem

To determine where the API error log resides, check the following:

1) Get the DSMI_LOG. DSMI_DIR, and DSMI_CONFIG variables for the running instance:


a) ps -elf | grep -i "db2sysc" | grep -i "<instance owner>"
b) ps eww <pid of db2sysc from the output of step 'a'>
Default values, if not specified
DSMI_LOG = </usr or /opt>/tivoli/tsm/client/api/<bin or bin64>
DSMI_DIR = </usr or /opt>/tivoli/tsm/client/api/<bin or bin64>
DSMI_CONFIG = </usr or /opt>/tivoli/tsm/client/api/<bin or bin64>/dsm.opt

2) check to see if the ERRORLOGNAME option is specified in the stanza of dsm.sys that the DB2 instance is using (this value will override DSMI_LOG).
a) DSMI_CONFIG variable will point to the dsm.opt used by DB2
b) Reference the corresponding SERVERNAME stanza in $DSMI_CONFIG (dsm.opt) file to the matching SERVERNAME value in $DSMI_DIR\dsm.sys and check to see if ERRORLOGNAME is specified

Resolving The Problem

1) Check the DSMI_LOG value to see which directory is specified and ensure that the instance owner owns that directory and/or has write permissions to create the error log file.
2) If specifying the ERRORLOGNAME, ensure that the directory and file name specified are both owned by the DB2 instance owner (or have write permissions).
3) If restarting DB2 manually, ensure that that you are the instance owner and that the DSMI variables are set correctly prior to running db2start, to ensure the process picks up the desired environment variables.

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Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21680301