IBM Support

An error occured while creating the model

Troubleshooting


Problem

Client recently upgraded their end user systems from XP to Win7 and now cannot run the generate FM extension from the CAC

Symptom

GUI error:

An error occured while creating the model

BMTReportNet log:


CCL-BIT-0005 A socket reported a communication error.
CAM_Connect=0xfffffff4 <errorDetail><errorCode>-12</errorCode><errorMessage>CAM-CRP-0026 The underlying socket: '10.128.59.107:9300' returned an error.</errorMessage><errorStack><errorCode>10060</errorCode><errorMessage>Could not connect the socket, errno: 0x274c(10060)</errorMessage></errorStack></errorDetail>

Cause

Client uses a custom dispatcher port on the BI dispatcher (9200). On the CAC machine, the Dispatcher URI for external applications was still set to the default 9300 port

Environment

BI CM / Primary BI dispatchers

Diagnosing The Problem

Review the BMTReportNet log for the error seen above

Resolving The Problem

Correct the port in Cognos Configuration > Environment for the Dispathcer URI for external applications so that it is set to the BI dispatcher External / Internal dispatcher URI

[{"Product":{"code":"SSPN2D","label":"Cognos Planning"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Contributor","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1;10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21679742