IBM Support

Maintaining S-TAP when upgrading database server operating system

Technote (FAQ)


Question

What must I do when I upgrade the operating system of a database server on which a Guardium S-TAP is installed?

Answer

When you upgrade the operating system (OS) on a database server where an S-TAP is installed, you must make sure that the S-TAP is ready to work with the new level of the operating system. In many cases you must uninstall and reinstall the S-TAP.
If you do not use Guardium Installation Manager (GIM) to maintain the S-TAP on this database server, you must always uninstall the S-TAP before you upgrade the operating system, and reinstall the S-TAP after the OS upgrade is complete, using an installer that is compatible with the upgraded OS.


If you use GIM to maintain the S-TAP on this database server, but your GIM client is at a release earlier than 9.0.0_r57263, you must uninstall the S-TAP before you upgrade the operating system, and reinstall the S-TAP after the OS upgrade is complete, using GIM. If you prefer, you can update the BUNDLE-GIM on this database server to release 9.0.0_r57263 or later, and use the approach described in the next paragraph. In order to use this GIM release, your Guardium system must be at version 9.1 (V9.1 is equivalent to V9.0 patch 100 or later).


If you use GIM to maintain the S-TAP on this database server, and your GIM client is at a release 9.0.0_r57263 or later, you can use GIM to update bundle S-TAP to the latest V9.1 version (the target STAP version must be higher than the one that is currently running on your system), using the process documented here:
http://www-01.ibm.com/support/knowledgecenter/SSMPHH_9.1.0/com.ibm.guardium91.doc/gim/topics/t_gim_os_upgrade.html

When the server is restarted after the OS upgrade, GIM recognizes that an upgrade has been performed and does not load KTAP, but the previous STAP is still present on the system and will be running. If a newer BUNDLE-STAP than currently installed is available on Fix Central, which is compatible with your upgraded database server, you can use GIM to upgrade the S-TAP to that bundle. As part of deploying the new S-TAP bundle, set the parameter KTAP_ENABLED=1. If you do not have a newer S-TAP bundle available, you must use GIM to uninstall and reinstall using the same BUNDLE_STAP version that was previously installed and is compatible with the upgraded OS. Check Fix Central to see whether a newer bundle is available for download.

Document information

More support for: IBM Security Guardium

Software version: 8.1, 8.2, 9.0, 9.1

Operating system(s): AIX, HP-UX, Linux, Solaris

Reference #: 1679002

Modified date: 13 August 2014


Translate this page: