IBM Support

Unable to launch TM1 Operations Console: Blank screen...

Troubleshooting


Problem

When trying to open TM1 Operations Console in Internet Explorer a blank screen appears.

Symptom

When clicking on the yellow error triangle in the left corner of the browser window following
Webpage error details are displayed:

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E)
Timestamp: Wed, 25 Jun 2014 09:41:30 UTC


Message: 'name' is null or not an object
Line: 15
Char: 4249
Code: 0
URI: http:/SERVERNAME:9510/pmhub/pm.dojo/dojo/dojo.js


Message: Object expected
Line: 144
Char: 2
Code: 0
URI: http://SERVERNAME.com:9510/pmhub/pm/opsconsole/WelcomeTM1.vm

Cause

This is likely due to the browser being set to use Compatibility Mode. A defect has been logged for the fact that Ops Cons doesn't work in Compatibility Mode and the APAR number is PI35026.

Also, certain dojo components used by Operations Console require IE 9 or later
Earlier versions of IE browser are not supported.

Resolving The Problem

To avoid this issue, do not use any form of Compatibility Mode.

To work around the issue, make sure that users access TM1 Operations Console using IE9 and above.

Also make sure that the Document mode is NOT set to 7 or 8. Document Mode can be accessed by pressing F12 and selecting the appropriate mode from the drop down list.



If using IE 10, set Browser Mode to IE10 and the Document Mode to Standards

Please note that in the newest versions of IE there is a setting called "Edge" which means the newest Document Mode.

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1 Operations Console","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21678053