IBM Support

"Message from webpage" ... "undefined" when browsing Cognos Connection

Troubleshooting


Problem

User launches Cognos Connection (http://servername/ibmcognos). User attempts to launch the Cognos Administration sections. A message repeatedly appears on the screen.

Symptom


Message from webpage
undefined

Cause

In some environments, the Cognos Connection website requires IE compatibility view enabled.

Resolving The Problem

Modify Internet Explorer so that it uses 'Compatibility View' for the Cognos application server's website.

Steps:

1. Launch Internet Explorer

2. Click the 'tools' icon, and then click 'Compatibility View settings':

3. Add the Cognos website into the list of websites:

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Connection","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21677662