Troubleshooting
Problem
Windows update kb2264107 causes IBM Cognos installation service to fail to startup successfully and will not function generating the following error:
Symptom
(1) Windows Patch causes Cognos to fail with JCAM_Crypto_JNI (Not found in java.library.path):
SCHWERWIEGEND: StandardWrapper.Throwable
java.lang.UnsatisfiedLinkError: JCAM_Crypto_JNI (Not found in java.library.path)
at java.lang.ClassLoader.loadLibraryWithPath(ClassLoader.java:1213)
at java.lang.ClassLoader.loadLibraryWithClassLoader(ClassLoader.java:1177)
at java.lang.System.loadLibrary(System.java:530)
at com.cognos.accman.jcam.crypto.jni.JNISystemProperties.<clinit>(JNISystemProperties.java:27)
at java.lang.J9VMInternals.initializeImpl(Native Method)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:236)
at com.cognos.accman.jcam.crypto.SystemProtectionSession._getRawKey(SystemProtectionSession.java:241)
at com.cognos.accman.jcam.crypto.SystemProtectionSession.<init>(SystemProtectionSession.java:52)
at com.cognos.accman.jcam.crypto.misc.Configuration.<init>(Configuration.java:77)
There may also be an error message in the cbs_run.log that matches the following string:
FATAL t[e48] CBSCryptoHelper failed to initialize crypto. |
(2) Windows Patch causes Framework Manager to fail with source/LogTypedLogger.cpp(272): CCLAssertError: CCL_THROW
Open Framework Manager and create a new project and the above error (2) is returned.
(3) Windows patch causes Cognos Analytics 11.x to recycle and the following error message inside cogserver.log file:
CM-CFG-5133 A Content Manager configuration error occurred while initializing the Plugin class
"com.cognos.cm.plugin.JNI.FMUpgradePluginJNI". Cause: FMMD_UpgradeCM(Not found in java.library.path) Stack trace:
java.lang.UnsatisfiedLinkError: FMMD_UpgradeCM (Not found in java.library.path).
Cause
The windows patch adds a new registry entry called CWDIllegalInDllSearch which switches the value to:
0xFFFFFFFF Removes the current working directory from the default DLL search order.
Diagnosing The Problem
Alternate steps to confirm if this is the issue without touching the registry entry:
1. Open command window
2. For a 64-bit install, add <cognos_install_directory>\bin64 path to the PATH environment variable temporarily. For a 32-bit install, add <cognos_install_directory>\bin. e.g. set PATH=C:\Program Files\ibm\cognos\c10\bin64;%PATH%
3. Change directory to the bin (32-bit install) or bin64 (64-bit install) directory, and run the script startup.bat to start cognos within the command window.
If the server starts up successfully without any JCAM_Crypto_JNI error, you are running into this problem and should proceed to the Resolving The Problem section to apply a permanent solution.
Resolving The Problem
Reset the value of the following CWDIllegalInDLLSearch registry entry to 0 (zero):
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SessionManager\CWDIllegalInDLLSearch
For further information see the following link on the full steps:
http://support.microsoft.com/kb/2264107
Note: Ensure the system is backed up before making any configuration/registry changes.
Alternatively, with the above registry key value set to '0xFFFFFFFF' (enabled) do the following:
- For a 64-bit install, add cognos/c10_64/bin64 and cognos/c10_64/cgi-bin to the SYSTEM PATH variable
- For a 32-bit install, add cognos/c10_64/bin and cognos/c10_64/cgi-bin to the SYSTEM PATH variable
Restart the service(s)
NB: Apply equivalent steps for Linux/Unix
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21676581