IBM Support

Receiving a JNDI error when first logging into Workplace XT

Troubleshooting


Problem

Attempt to login for the first time after install and deployment of Filenet Workplace XT results in an error.

Symptom

Following error is received during Workplace XT login

<Error> <HTTP> <BEA-101017> <[ServletContext@510420892[app:WorkplaceXT

module:WorkplaceXT path:null spec-version:null]] Root cause of

ServletException.

com.filenet.wcm.api.RemoteServerException: com.filenet.api.exception.

EngineRuntimeException;The JNDI cannot be accessed. Message was: null

[Code=null]; OMFC/TheNetwork/NoOp//API_UNEXPECTED_JNDI_ERROR

at com.filenet.wcm.apps.server.controller.

WcmWorkplaceController.handleEvent(WcmWorkplaceController.java:612)

at com.filenet.wcm.toolkit.server.base.WcmController.handleEvent

(WcmController.java:3150)

at jsp_servlet.__wcmdefault._jspService(__wcmdefault.java:90)

at weblogic.servlet.jsp.JspBase.service(JspBase.java:34)

at weblogic.servlet.internal.

StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:

242)

Cause

WorkplaceXT is unable to communicate with the Content Engine

Resolving The Problem

When the host file on the WorkplaceXT server was originally modified the Content Engine Servername was mistyped. After correcting the servername to the proper format the login worked.

[{"Product":{"code":"SSNVNV","label":"FileNet Content Manager"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"5.1.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSNVNV","label":"FileNet Content Manager"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
21 January 2022

UID

swg21675524