IBM Support

Remote backup stays in pending state.

Troubleshooting


Problem

The replication to the remote location might stay in pending state. How to solve this?

Symptom

The backup of protected objects can be observed to be in pending state while the remote location is reachable:

Cause

The remote location setting was set to an unreachable or non existent location.

Diagnosing The Problem

If the remote location setting was set to an unreachable or non existent location and some objects were marked to be saved to that location, even if the parameter is reset to the original location or some other reachable location, the files queued for replication to the incorrect location will stay in pending state and block the replication.

Resolving The Problem

The problem can be seen on FastBack for Workstations versions lower than 6.3.1.2.
At 6.3.1.2 or higher this will not be observed as the object bound to the incorrect remote location will automatically be saved to the correct one as soon as it is set in the configuration and that it is reachable.

In case that the FastBack for Workstation client cannot be upgraded, there are two ways to solve the problem once the correct remote location has been set..

For stand alone clients :
====================

1. Open the web interface
2. Click on the icon in the lower right corner that shows the status of the client
3. Click on "Remote Backup"

4. This will bring up the Remote Backup Status pop-up :
5. Click on "Skip" if there are only a few files pending or on "Stop"
6. The newly changed protected objects will be again sent to the correct location.
7. The skipped objects or whole pending object list will need to be saved again to ensure these are sent to the remote location. To achieve that, either edit/change the objects so these will be saved or initiate an initial scan through the web GUI.

For clients managed by the Central Administration Console :
==================================================

1. Create a script through the console and send it to all the affected clients as shown below.

thread-status command="abort" priority=5
thread-status command="abort" priority=3

2. Trigger a full backup after the issue is fixed so that the files that were deleted from the queue get backed up.
This scan can also be done through a script using the command below.

synchronize

Be careful about the amount of affected clients as this could be a very heavy load for the network if numerous clients do a full backup at the same time.

[{"Product":{"code":"SSER9E","label":"IBM Spectrum Protect for Workstations"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1.3;7.1.4;8.1","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21673557