Question & Answer
Question
This technical note covers the procedure for collecting troubleshooting data for IBM Tivoli Widget Library (TWL) specifically in DASH for JazzSM.
Cause
Note: This document covers the TWL widget mustgather collection procedures specifically for Jazz for Service Management/DASH. For support of TWL widgets in any other product besides JazzSM/DASH, consult that product's documentation.
You can use trace logging to assist in monitoring and diagnosing problems. Since trace logs can be quite verbose and include many unrelated errors, resetting the logs and then reproducing the problem issue can reduce the time required for log analysis for specific issues.
Answer
Steps to enable tracing.
Enable trace logging:
- Log into the DASH. After logging in navigate to Console Settings > Websphere Administrative Console.
- Navigate to Troubleshooting -> Logs & Trace
- Click on the Server1 -> Select Diagnostic Trace Service. Increase the Maximum Number of Historical Files from 1 to 10.
- Click Apply, then select Change Log Detail Levels.
- Click on Runtime tab to enable tracing for the TWL widget/process that is currently running. Enabling tracing from the Runtime tab will keep tracing active until the next time the DASH server process is stopped. To make tracing persistent even after stopping and restarting the DASH server process click the Configuration tab instead.
- Clear the trace string in the Groups box and replace it with the following:
com.ibm.tivoli.rest.*=all:com.ibm.tivoli.rest=finest:com.ibm.usmi.*=all:com.ibm.sysmgmt.utils=all
For the Connection manager (data provider related issues) you will want to enable all for the following components:
*=info: com.ibm.isclite.rest.*=all:com.ibm.tivoli.conmgr.*=all
- Click on the Apply button.
- If you enabled tracing from the Configuration tab in step 4, then click the "Save" link that appears at the top of the page. ("Save to master configuration")
Once tracing is enabled, reproduce the TWL issue and gather the following details to attach them to the associated Problem Management Record (PMR):
- Steps to reproduce the issue (with the functionality used in the widget - for example: filter; dynamic update, eventing, etc)
- Take screenshots of the failing widgets or page with error.
- Note the widgets affected (such as List, Table, Gauge, etc)
- Data provider details - name of the data provider, version, data source and data sets being used for the widget
- JazzSM and Browser version used to reproduce the issue
- Note the timeline estimates that the issue was reproduced so that the issue can pinpoint issues with the trace log entries.
- Enable Firefox Firebug/console output of any browser to capture client side debugging -- this is useful to observe response and request which are being sent to the server
Step to capture Firefox Firebug log can be found here
Run the log collector program to collect logs using steps below:
- Change the directory to <JazzInstallHome>/ui/bin
- Run the following command:
./consoleLogCollector.sh or .bat
Send us the console_logs.zip file located in <JazzInstallHome>/logs directory
Please also provide the DASH system info:
<JazzInstallHome>/ui/bin/consolecli.sh SystemInfo --outputFile <output file>
Upload the resulting output file to the PMR.
Product Synonym
DASH
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Document Information
Modified date:
17 June 2018
UID
swg21671904