Troubleshooting
Problem
After upgrading Content Platform Engine (CPE) to 5.2.0.3-P8CPE-FP003, customers using Workplace (Application Engine) will not be able to launch Process Engine applets such as Process Administrator and Process Configuration Console.
Symptom
1. Unable to launch Process Engine applets from Workplace.
2. Splash screen for the applet appears to hang.
3. Errors like java.lang.ClassNotFoundException: com.filenet.api.core.EngineObject are seen in the Java plug-in console on the client (browser) workstation.
Call Stack:
Exception in thread "VWSplashWindow" java.lang.NoClassDefFoundError: com/filenet/api/core/EngineObject
at filenet.vw.idm.trident.VWTridentFactory.getSavedVWSession(VWTridentFactory.java:665)
at filenet.vw.toolkit.utils.dialog.VWLogonDialog.isLogonOK(VWLogonDialog.java:226)
at filenet.vw.toolkit.utils.VWSessionInfo.logon(VWSessionInfo.java:1972)
at filenet.vw.toolkit.utils.VWSessionInfo.verifyLogon(VWSessionInfo.java:1350)
at filenet.vw.toolkit.utils.VWSessionInfo.verifyLogon(VWSessionInfo.java:1324)
at filenet.vw.apps.config.VWConfigApplet.startProcessing(VWConfigApplet.java:113)
at filenet.vw.toolkit.utils.VWSplashWindow.run(VWSplashWindow.java:175)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: com.filenet.api.core.EngineObject
at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 8 more
preloader: Stop progressCheck thread
Cause
The Jace.jar file is not loaded into the Java Cache, so the com/filenet/api/core/EngineObject class cannot be found.
Resolving The Problem
Replace the appletParameters.properties file (normally located in the <installpath>\IBM\FileNet\AE\Workplace\WEB-INF directory) with this appletParameters.properties file:
Once appletParameters.properties file has been replaced, rebuild the EAR and/or WAR file using the tools in the <installpath>\IBM\FileNet\AE\deploy directory.
After rebuilding the EAR file, redeploy the application to the application server.
After successfully redeploying the EAR file, the Process Engine Java applets should now open correctly.
Related Information
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21671521